View Issue Details

IDProjectCategoryView StatusLast Update
0019492phpList 3 applicationGeneralpublic05-08-19 16:26
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Product Version3.4.1 
Target Version3.4.5Fixed in Version3.4.4 
Summary0019492: Design new readme page for phpList 3 on GitHub
DescriptionMake a pretty readme page for the phpList 3 github repo.

For example:

https://github.com/getfider/fider/blob/master/README.md
TagsNo tags attached.

Activities

brunilda

07-02-19 09:45

manager   ~0061837

I`m working on this issue.

rudolf

07-02-19 15:36

administrator   ~0061842

First sample, feel free to suggest changes.

https://xd.adobe.com/view/1f3aefb5-1d48-4319-bebc-6d0771260f6e-4a69/

readme on GitHub.jpg (912,632 bytes)

samtuke

07-02-19 18:58

administrator   ~0061843

@rudolf I have provided feedback there. Some of it is simply minor text updates, which is not specifically design related - sorry about that.

xheni

07-02-19 19:22

administrator   ~0061844

Last edited: 07-02-19 19:30

View 2 revisions

I would also suggest adding some nice badges for eg: downloads and discourse topics
Please see https://shields.io/

rudolf

08-02-19 10:40

administrator   ~0061847

Thank you for the suggestions, Updated.
@xheni, could you please be more specific on which phrases or sections should I add the badges.

xheni

08-02-19 14:37

administrator   ~0061855

Last edited: 08-02-19 14:37

View 2 revisions

@rudolf The badges are set on the top of readme.md usually and there are already some as below:



samtuke

15-02-19 11:32

administrator   ~0061902

@rudolf did you see my comments on XD from before?

@xheni it looks to me as if the shields buttons are the same, just centered instead of left aligned, no?

rudolf

15-02-19 13:16

administrator   ~0061903

@samtuke, yes, except comment 4, which I can't remove because those are the links indicated by the graphics above that section. Only if we chose to remove the links completely. What do you say?

samtuke

15-02-19 13:23

administrator   ~0061904

@rudolf Can the larger icons for these items be linked, thereby removing the need for the additional buttons? Those buttons look like a repition somehow to me.

rudolf

15-02-19 13:45

administrator   ~0061905

Last edited: 15-02-19 13:45

View 2 revisions

@samtuke Yes, seems like it is possible. I removed the badges and updated the template.

rudolf

15-02-19 13:49

administrator   ~0061906

Putting the link here, so anyone can view it (doesn't need permissions):
https://xd.adobe.com/view/38f504a3-88b1-4b1d-7380-f364b1ea2210-4ec4/

brunilda

14-05-19 16:04

manager   ~0062206

@rudolf
Please have a look on this link:
https://github.com/phpList/phplist3/tree/BrunildaDosti-readme-design

samtuke

14-05-19 16:18

administrator   ~0062207

@brunilda Version number needs updating again from 338 (this was fixed in a previous commit). Also using github style badges for documentation like "system requirements" is confusing, as those badges are usuallyuaes for dynamic content, like test status or version number. I think it's better to use another button style. For those links.

brunilda

15-05-19 10:55

manager   ~0062208

@samtuke Fixed button version and theme icon issues.
https://github.com/phpList/phplist3/tree/BrunildaDosti-readme-design

brunilda

11-07-19 16:12

manager   ~0062557

PR link:
https://github.com/phpList/phplist3/pull/532

suela

05-08-19 16:26

administrator   ~0062600

Final PR on this: https://github.com/phpList/phplist3/pull/577