View Issue Details

IDProjectCategoryView StatusLast Update
0019453phpList 3 applicationpluginspublic07-11-18 10:05
Reporterduncanc 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionopen 
Product Version3.3.5 
Target Version3.3.6Fixed in Version 
Summary0019453: Some plugins were disabled after upgrading to release 3.3.5
DescriptionAfter upgrading to release 3.3.5 I found that several plugins that were enabled previously were now disabled.

The cause is a mistake in an earlier change I made https://github.com/phpList/phplist3/pull/379 that tests whether an already initialised plugin can be enabled. That test is done while the plugins are being created, so a dependency plugin may well not yet have been created and the test will fail.

The test for enabling needs to be moved to a point where all plugins have been created.

See https://github.com/phpList/phplist3/pull/411

TagsNo tags attached.

Activities

duncanc

12-10-18 08:44

developer   ~0061237

I wondered why this problem had not been noticed before and have just realised that release 3.3.5 is the first to include the earlier pull request, 379.
I had thought it was included in release 3.3.4, but that was not the case.

samtuke

12-10-18 09:09

administrator   ~0061238

Sounds like the release notes of 3.3.5 need updating then? @suela