View Issue Details

IDProjectCategoryView StatusLast Update
0019329phpList 3 applicationAll Otherpublic01-10-18 10:35
Reportersamtuke 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Product Version3.3.3 
Target Version3.3.5Fixed in Version3.4.0 
Summary0019329: Replace 'powered by' buttons with new hi-res images from Ura
DescriptionReplace all existing images with new ones, including in campaigns and public subscribe pages.

Images: https://github.com/uracreative/works/tree/master/phpList/Buttons/Export
TagsNo tags attached.

Activities

user5081

19-07-18 22:25

  ~0060922

@martin we need to replace this 3 images, but I don't have access to this places, also I don't know where is the subdomain "powered.phplist.com'. Can you help me?

https://d3u7tsw7cvar0t.cloudfront.net/images/power-phplist.png
http://powered.phplist.com/images/dev/power-phplist.png
http://powered.phplist.com/images/power-phplist.png

martin

20-07-18 08:38

administrator   ~0060923

Last edited: 20-07-18 08:40

View 2 revisions

Here:
Amazon S3 -> powered.phplist/images
Amazon S3 -> powered.phplist/images/dev

cloudfront should refresh automatically from the first location, I suppose

If needed, I can upload there myself, if you tell me which one to use. (black.png ?)

samtuke

20-07-18 09:53

administrator   ~0060924

@marie Is the layout, CSS etc ready on the subscribe pages and email templates? Once the files on the server are changed, they will be used immediately. Surely it's better to add the images rather than replace the old ones on Aws so that old campaigns and application versions look correct?

user5081

21-07-18 19:45

  ~0060928

The image to use is this: https://github.com/uracreative/works/blob/master/phpList/Buttons/Export/PNG/black.png
There are no need to change CSS. It is OK to replace actual image with this black.png. Old emails will look OK with this black.png image. Both images have same size and both have black background. I don't see any need to replace all html calls to this image in the application. Tell me if there is a reason that i am not seeing. If not, I will replace the images included in the application directory to complete the change, and Martin should replace the images in this note: https://mantis.phplist.org/view.php?id=19329#c60922

user5081

25-07-18 23:18

  ~0060935

Reminder sent to: samtuke

So may I continue with this change? Is this way ok for you?

samtuke

26-07-18 15:30

administrator   ~0060937

@marie Using new images is a better option because it will cause no surprise to users of existing / old versions of phpList, and allow us to measure the impact of the new images over the old ones (e.g. self-hosted user disatisfaction and referals / clicks). Please update the link references for the new image and use the highest DPI version possible so they are not pixellated e.g. on mobile devices.

FYI @michiel

michiel

29-07-18 10:19

manager   ~0060952

We need to be careful with doing this. Remember that not everyone upgrades, in fact a lot of people don't. If the image requires different CSS to work, this will break everyone who has the old one and therefore look really bad.

We should not change the images on S3, as they all refer to older versions. Instead we should only upload the new ones for newer versions.

Eg
https://d3u7tsw7cvar0t.cloudfront.net/images/2.8.1/power-phplist.png
https://d3u7tsw7cvar0t.cloudfront.net/images/2.9.4/power-phplist.png
https://d3u7tsw7cvar0t.cloudfront.net/images/3.2.4/power-phplist.png

Also powered.phplist.com is the same location, but it does not have a certificate, so cannot be SSL.

These are only the images that are on the subscribe pages. The image that is included in the emails are coded in the code:

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/connect.php#L1722

michiel

29-07-18 10:30

manager   ~0060953

Mariela, if you change this image, it will automatically go up to S3 on a new release:

https://github.com/phpList/phplist3/blob/master/public_html/lists/images/power-phplist.png

Then assign to me, and I will update the one in the code.

user5081

31-07-18 21:08

  ~0060964

Done:
https://github.com/phpList/phplist3/pull/382

samtuke

20-08-18 10:49

administrator   ~0061024

@michiel This is ready for you to apply the changes.

samtuke

06-09-18 10:42

administrator   ~0061062

Ping

samtuke

06-09-18 11:44

administrator   ~0061064

This has been updated on amazon s3 but the codebase changes have not been cherry picked to the release branch, they are only in master, so should appear automatically in v3.4.0