View Issue Details

IDProjectCategoryView StatusLast Update
0019309phpList 3 applicationInstallationpublic28-08-18 10:05
Reportermichiel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version3.3.4-RC1 
Target Version3.3.4Fixed in Version3.3.4 - RC3 
Summary0019309: upgrade throws errors
DescriptionUpgrading to 3.3.4-RC1

Your database version: 3.3.2-RC6

Please wait, upgrading your database, do not interrupt
Database error 1091 while doing query Can't DROP 'urlindex'; check that column/key exists
Database error 1170 while doing query BLOB/TEXT column 'url' used in key specification without a key length
Giving a UUID to your subscribers and campaigns. If you have a lot of them, this may take a while. If the page times out, you can reload. Or otherwise try to run the upgrade from commandline instead. More information

TagsNo tags attached.

Activities

xheni

03-07-18 19:33

administrator   ~0060834

Thanks. That looks bad and didn't appear in my testing, will take a look first thing tomorrow.

michiel

06-07-18 21:30

manager   ~0060848

this is ok in 3.3.4-RC2

xheni

18-07-18 13:04

administrator   ~0060914

Created a function to check if indexes exist here --> https://github.com/phpList/phplist3/pull/377

michiel

29-07-18 22:08

manager   ~0060960


this happened for me on 3.3.4-RC3

suela

30-07-18 11:41

administrator   ~0060962

Yes I am getting this error with the Docker image too:
Database error 1170 while doing query BLOB/TEXT column 'url' used in key specification without a key length

However I don't get any error when using the GItHub copy

xheni

30-07-18 20:13

administrator   ~0060963

so the "Database error 1091 while doing query Can't DROP 'urlindex'; check that column/key exists" is not happening again? Only Database error 1170?
 I couldn't reproduce it on my installation and I'm not sure what is it causing it on docker, but I will check.

samtuke

20-08-18 10:45

administrator   ~0061021

Related to https://github.com/phpList/phplist3/pull/389