View Issue Details

IDProjectCategoryView StatusLast Update
0019267phpList 3 applicationSubscribe Processpublic06-08-18 09:49
Reportersamtuke 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
PlatformLinuxOSFedoraOS Version26
Product Version3.3.3 
Target Version3.3.4Fixed in Version3.3.4 
Summary0019267: Provide 'Reset template' button on 'Add new subscribe page'
DescriptionCurrently, when the default subscribe page template is updated, e.g. in the Trevelin theme, existing phpList installations do not get the benefit, as the default subscribe page template is stored in the database during the installation initialistion, and can never be automatically changed after that time. This is because updating the default template may overwrite changes made by the admin to the template. See the following section of the 'Settings' page: "subscription-ui settings". Users are not even aware that improvements to the template are available.

To make it possible for admins to update to the latest default template, add a button to 'Reset template' to the 'Subscribe pages' page (lists/admin/?page=spage). This button would effectively reset the value of the 'subscription-ui settings' to the (updated) defaults and introduce any updates available. Additional subscribe pages which have been added by the admin should not be affected as they store their own page content separately.
TagsNo tags attached.

Relationships

related to 0019344 closedxheni Extend "Reset style to default" functionality to apply changes to /lists page and other public pages 

Activities

xheni

28-06-18 12:33

administrator   ~0060802

PRs: https://github.com/phpList/phplist3/pull/359
https://github.com/phpList/phplist-ui-bootlist/pull/60

suela

05-07-18 07:48

administrator   ~0060841

@xheni, this is not working for me. There is not working for me.
The changes are not applied and the pop up to confirm reset is not displayed.

xheni

05-07-18 09:06

administrator   ~0060842

You should clear cache.

suela

05-07-18 09:07

administrator   ~0060843

Yes, working now