View Issue Details

IDProjectCategoryView StatusLast Update
0019257phpList Internationalisation[phpList 3 application] Internationalization (l18n)public11-06-18 13:25
ReporterDragonrider5 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version[phpList 3 application] 3.3.0 
Target Version[phpList 3 application] 3.3.4Fixed in Version[phpList 3 application] 3.3.3 
Summary0019257: Contact Administrator not translatable
DescriptionIt's been reported in the forums that in 3.3.3 that the new string displayed on the subscribe to our lists page for "Contact the Administrator" is not translated and is in fact hard coded in the lists/index.php file. (Line 375)
https://discuss.phplist.org/t/new-string-contact-the-administrator-in-3-3-3/4018

Steps To Reproducejust visit subscribe page
Additional InformationI've added the string $strContactAdmin = "Contact the Administrator"; to lists/texts/english.ini

and changed

s(‘Contact the administrator’)

to:

$GLOBALS[‘strContactAdmin’]

in lists/index.php

This seems to solve the reported issue, perhaps for consideration for the next update?
TagsNo tags attached.

Activities

samtuke

28-05-18 07:56

administrator   ~0060644

@Dragonrider5 thanks for reporting this. It appears that the string is in fact translatable (the s() function is equivalent to using $GLOBALS['']). But the string is not listed on Pootle (translate.phplst.org). It may be that the automatic translation process isn't working. We shall investigate.

duncanc

28-05-18 10:31

updater   ~0060649

It's not quite the case that s() and $GLOBALS[''] are equivalent because they can be using different languages.
s() will use the language of the current administrator, defaulting to $default_system_language, so hasn't really been designed for use on the public pages where there is no current admin.

The public pages have their own default language through $language_module. The strings on the /lists page will be translated using that. So if that is german.inc then the preferences text $strPreferencesTitle is displayed as Einstellungen ändern regardless of the default admin language.

I guess that the default admin language and default public page language will often be the same, but someone might want the admin pages to be in English and have public pages in the local language. It might be best to continue using the $GLOBALS approach, although I have no idea how new strings get translated.

samtuke

29-05-18 09:37

administrator   ~0060660

@duncanc Great point, thanks. I wasn't aware of that.

samtuke

30-05-18 13:05

administrator   ~0060665

Potentially related: in the forum it has been reported that this string is also not translating properly: $strPersonalLocationSent
Original report: https://discuss.phplist.org/t/two-bugs-in-the-automated-translation-from-english-to-german/4072

xheni

30-05-18 14:36

administrator   ~0060667

PRs: https://github.com/phpList/phplist3/pull/339
& https://github.com/phpList/phplist-lan-texts/pull/18

Issue History

Date Modified Username Field Change
27-05-18 09:44 Dragonrider5 New Issue
28-05-18 07:56 samtuke Note Added: 0060644
28-05-18 07:56 samtuke Status new => assigned
28-05-18 07:56 samtuke Target Version => 3.3.4
28-05-18 10:31 duncanc Note Added: 0060649
29-05-18 09:37 samtuke Note Added: 0060660
30-05-18 13:05 samtuke Note Added: 0060665
30-05-18 14:36 xheni Note Added: 0060667
11-06-18 13:25 xheni Status assigned => resolved
11-06-18 13:25 xheni Resolution open => fixed
11-06-18 13:25 xheni Fixed in Version => 3.3.3