View Issue Details

IDProjectCategoryView StatusLast Update
0019240phpList 3 applicationSubscriber Importpublic24-05-18 20:55
Reportersuela 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.3 
Target Version3.3.4Fixed in Version3.3.3 
Summary0019240: phplist_user_user table not updated correctly when blacklisted removed subscriber is re-imported
DescriptionWhen you import a subscriber and then blacklist the email all three tables: phplist_user_user & phplist_user_blacklist & phplist_user_blacklist_data will show it as blacklisted.

When you remove it from the system using "Remove Subscriber" button on the user profile, the email will still be on phplist_user_blacklist table as blacklisted but be removed from phplist_user_user

When you re-import the same email: user_blacklist_data will be showing them as blacklisted but the "blacklisted" value on phplist_user_user table will be zero. Because of that the "Delete all blacklisted subscribers" button won't work for this email.
TagsNo tags attached.

Activities