View Issue Details

IDProjectCategoryView StatusLast Update
0019235phpList 3 applicationInstallationpublic17-05-18 20:19
Reporterprashantt 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSCentosOS Version6.4(Final)
Product Version3.3.2-RC2 
Target VersionFixed in Version 
Summary0019235: 'Phplist version 3.3.2 and 3.3.3 throw syntax error unexpected '^' while installation on PHP 5.4 as well as 5.5'
DescriptionHi,
I tried manual installation of phpList 3.3.3 on CentOS 6.4 Linux on PHP 5.4.45 as well as PHP 5.5.38 .While starting the installation i get the following error :

Array ( [type] => 4 [message] => syntax error, unexpected '^', expecting ',' or ';' [file] => /home/soft/public_html/manual/phplist333/admin/plugins/SegmentPlugin.php [line] => 36 )

However script runs fine on PHP 5.6.What's causing the issue ?.Could you please reproduce it at your side?.Even phpList 3.3.2 throws the same issue.



Steps To Reproduce1)Enter config file details .
2)visit http:://{{phplisturl}}/admin and following error is thrown

Array ( [type] => 4 [message] => syntax error, unexpected '^', expecting ',' or ';' [file] => /home/soft/public_html/manual/phplist333/admin/plugins/SegmentPlugin.php [line] => 36 ) .
TagsNo tags attached.

Relationships

duplicate of 0019233 resolvedsuela phpList 3 plugins Syntax error using bitwise operator in class var definition with php 5.4.16 

Activities

michiel

17-05-18 20:19

manager   ~0060601


Duplicate of 0019233