View Issue Details

IDProjectCategoryView StatusLast Update
0019234phpList 3 applicationInterface - Administratorpublic16-05-18 20:59
Reportersuela Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.2-RC2 
Target Version3.3.3 
Summary0019234: Default theme value is "Dressprow", but it will only be displayed in Firefox
DescriptionOn first install when using chrome the Theme displayed is Trevelin, but the value of the theme in settings is set to "Dressprow".
Noticed when doing the initialization on Firefox were I get Dressprow displayed since the begining.
TagsNo tags attached.

Activities

michiel

15-05-18 22:35

administrator   ~0060590

Yes, I noticed something similar. I will need to fix that before rolling out 3.3.3

FYI @samtuke

michiel

15-05-18 22:47

administrator   ~0060591


I think it's ok now. Where did you experience this? If you can still replicate it, can you provide the steps?

If you refresh the 3.3.3 docker version now, it should be fine.

You will need to run

docker-compose -f [dockerfile] pull
before you run
docker-compose -f [dockerfile] up

suela

15-05-18 23:25

administrator   ~0060592

I am still having problems on Firefox. The default theme value is set to Trevelin now, but it's showing dressprow.
Just try opening localhost/list/admin on firefox to reproduce the issue

samtuke

16-05-18 10:51

administrator   ~0060593

Testing the Sourceforge version of the RC, I do not experience this issue: on a fresh install, using private browsing, the default theme is Trevelin and listed as Trevelin on the settings page.

samtuke

16-05-18 11:03

administrator   ~0060594

Also testing on docker I cannot replicate this with a fresh checkout of all docker images. The first login page, and the app once logged in, using a private tab, both use Trevelin.

xheni

16-05-18 11:36

administrator   ~0060595

I cannot reproduce this too.

samtuke

16-05-18 11:44

administrator   ~0060596

@suela One possibility is that some of the docker images that you're using are outdated. Apparently the way the system works currently does not force images which are not the primary image being tested to updated when updates are available. E.g. if you update the phpList application docker image then the trevelin or database images will not update automatically, even though updates are available. In this case the changes made by Michiel were to the theme I believe (adding theme_info files to theme directories). This could explain why we see different behaviour on our machines. Michiel will work on changing this behaviour in future so that updates to all related repositories are pulled automatically. A workaround for the time being is to delete and re-download all related docker images. These pages explain how to remove all docker images:
https://techoverflow.net/2013/10/22/docker-remove-all-images-and-containers/
https://www.digitalocean.com/community/tutorials/how-to-remove-docker-images-containers-and-volumes
Ultimately this should be documented in the wiki.