View Issue Details

IDProjectCategoryView StatusLast Update
0019195phpList 3 applicationGeneralpublic02-05-18 11:30
Reporterpmcaron Assigned To 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionopen 
PlatformWindowsOSServerOS Version2016
Product Version3.3.1 
Target Version3.3.2Fixed in Version3.3.2 
Summary0019195: Error on screen
DescriptionFatal error: Uncaught ErrorException: The each() function is deprecated. This message will be suppressed on further calls in C:\websites\phplist\lists\admin\date.php:153 Stack trace: #0 [internal function]: phpList\plugin\Common\Exception::errorHandler(8192, 'The each() func...', 'C:\\websites\\php...', 153, Array) #1 C:\websites\phplist\lists\admin\date.php(153): each(Array) #2 C:\websites\phplist\lists\admin\send_core.php(749): date->showInput('embargo', '', Array) #3 C:\websites\phplist\lists\admin\send.php(122): include('C:\\websites\\php...') #4 C:\websites\phplist\lists\admin\index.php(700): include('C:\\websites\\php...') #5 {main} thrown in C:\websites\phplist\lists\admin\date.php on line 153
phpList version 3.3.1
Steps To ReproduceOccurs when editing or starting an new campaign.
TagsNo tags attached.

Activities

duncanc

23-04-18 12:32

updater   ~0060462

This is caused by one of your installed plugins incorrectly treating deprecated warnings as errors. Please state which plugins you have installed, and also update each to the latest version.

pmcaron

23-04-18 12:59

reporter   ~0060463

Hello Duncan,
Please to say hello again after having had your efficient help in "Upwork".
I have the following plugins :

Campaigns
CKEditor
Common
Contentareas
Segment

I have updated all of them to no avail.
But the CKEditor does not have an update button... could it be that one ?
Would be a good candidate sincr the error appears when pages are called where it is present ...

Regards

pmcaron

23-04-18 13:04

reporter   ~0060464

Hi Duncan,
No change when exchanging CKeditor for FCKeditor ...

I also changed to PHP 7.2.2 ...
Could that be the reason ?

duncanc

23-04-18 13:41

updater   ~0060465

Yes, the problem occurs with php 7.2. Try disabling the Content Areas plugin, you should then be able to continue. I cannot fix the problem straightaway but if you need the plugin then comment out lines 118, 119 and 134 of file ContentAreas.php from

        $level = error_reporting(E_ALL | E_STRICT);
        set_error_handler('phpList\plugin\Common\Exception::errorHandler', E_ALL | E_STRICT);
        error_reporting($level);
to
        // $level = error_reporting(E_ALL | E_STRICT);
        // set_error_handler('phpList\plugin\Common\Exception::errorHandler', E_ALL | E_STRICT);
        // error_reporting($level);

pmcaron

23-04-18 13:59

reporter   ~0060466

Many thanks Duncan, that works indeed.
I have no immediate need for the Content Areas plugin. Is this to be fixed in a near future ?
Regards.

duncanc

24-04-18 06:03

updater   ~0060469

There is a new version, 1.8.3+20180423, of the Content Areas plugin that should fix the problem.

pmcaron

24-04-18 22:28

reporter   ~0060474

Updated and works fine. Thanks.