View Issue Details

IDProjectCategoryView StatusLast Update
0019187phpList 3 applicationGeneralpublic12-05-18 14:58
ReportersamtukeAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Target Version3.3.3Fixed in Version3.3.3 
Summary0019187: Add draft campaign for use with invite plugin available in new installations
DescriptionTo make the invite plugin easier to use, include the attached default campaign as a draft in all new installations.
TagsNo tags attached.

Relationships

related to 0019148 resolvedxheni Add documentation on subscriber data placeholders in contextual help 
child of 0019032 newsamtuke [META] Changes for easier GDPR compliance 

Activities

samtuke

18-04-18 11:48

manager  

tmp.html (850 bytes)   
<p>Hi [FIRST NAME], remember us? You first signed up for our email newsletter on&nbsp;[ENTERED] -- please <a href="[CONFIRMATIONURL]" title="Confirm subscription">click here</a> to confirm that you&#39;re happy to continue receiving our messages:</p>

<p><strong><a href="[CONFIRMATIONURL]" title="Confirm subscription">Continue receiving messages</a></strong></p>

<p><u>If you do not confirm using this link then you won&#39;t hear from us again</u>.</p>

<p>While you&#39;re at it, you can also update your preferences, including your email address or other details, by clicking here:</p>

<p><strong><a href="[PREFERENCESURL]">Update preferences</a></strong></p>

<p>By confirming your membership and keeping your details up to date, you&#39;re helping us to manage and protect your data in accordance with best practices.</p>

<p>Thank you!</p>
tmp.html (850 bytes)   

samtuke

11-05-18 19:15

manager   ~0060574

@xheni After downloading a tarball from your branch (https://github.com/phpList/phplist3/tree/invite-message) on a fresh install, initialising a new database, no draft campaigns are listed within the installation. I have not tried upgrading. What scenarios have you tested so far?

xheni

11-05-18 19:32

developer   ~0060575

@samtuke Strange because it is listed on my side when I do a fresh install. I have also tried upgrading.

samtuke

12-05-18 12:45

manager   ~0060576

@xheni There was a space before the uuid in the SQL insert query, which caused it to fail because the value was too long. Now fixed, and it's working properly on fresh installs during my local testing.