View Issue Details

IDProjectCategoryView StatusLast Update
0019164phpList 3 applicationInterface - Frontendpublic06-06-18 22:08
Reportersuela Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version3.3.2-RC3 
Target Version3.3.4 
Summary0019164: Send test from Template only available for System Template
DescriptionWhile the option to send a test of the Template using the "Send Test" button on the template page is only possible with the System Template, the message that shows that for the user is only displayed after.

There are are two ways to resolve this:
1. Removing the send test button from that page (but only keeping it for the system template maybe is not that easy)
2. Making it possible to be used with templates created by the user too.

Screenshot attached.
TagsNo tags attached.

Activities

suela

06-04-18 15:29

administrator  

SendTestTemplate.jpg (91,939 bytes)   
SendTestTemplate.jpg (91,939 bytes)   

user5081

02-06-18 18:54

  ~0060677

https://github.com/phpList/phplist3/pull/343

michiel

03-06-18 09:29

administrator   ~0060680


This is not as simple as commenting out the line to select only the system template.

https://github.com/phpList/phplist3/pull/343/files

The send test on templates is not like campaigns. There is no content to send. So, the send Test in templates will send the transaction messages as the content.

That is the reason we are only sending tests on templates with the system template.

If you want that to change you'd need to think about what content to send in the test messages, or maybe empty content? Or Lorem Ipsum.

FYI @samtuke