View Issue Details

IDProjectCategoryView StatusLast Update
0019140phplist applicationInterface - Administratorpublic11-04-18 11:56
Reportersuela 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.2-RC3 
Target VersiondocumentationFixed in Version 
Summary0019140: Text tab is missing
DescriptionWhen trying to send a campaign the "Text" tab is missing. See screenshot attached.
TagsNo tags attached.

Activities

suela

28-03-18 12:40

administrator  

textTab.jpg (88,806 bytes)
textTab.jpg (88,806 bytes)

michiel

28-03-18 13:19

manager   ~0060185


what is your config value for

https://resources.phplist.com/system/config/use_manual_text_part

suela

28-03-18 13:33

administrator   ~0060186

That was set to 1 by default. I changed it to 0 but I can't see any any change.

michiel

28-03-18 15:59

manager   ~0060188


It should be 1. If it's 0, the TEXT tab will disappear.

Please double check your config file. I cannot replicate this on my system.

suela

02-04-18 13:00

administrator   ~0060248

I installed the new RC3 and still the same problem. The value is 1 by default.

michiel

09-04-18 21:54

manager   ~0060349


I can't replicate this. When I set USE_MANUAL_TEXT_PART to 1, the tab appears.

By default it is 0

https://resources.phplist.com/system/config/use_manual_text_part

samtuke

10-04-18 17:09

administrator   ~0060356

@michiel I can replicate this on a fresh install of 3.3.2 RC3, with default config files and new database. The value of USE_MANUAL_TEXT_PART has no impact.

michiel

10-04-18 22:39

manager   ~0060368

Weird. Are you sure you are editing the correct config file?

See https://screenshots.firefox.com/byH4jJ7vN5QsRikr/localhost

samtuke

11-04-18 09:55

administrator   ~0060372

@michiel On a fresh install it shouldn't be necessary to edit any configuration file because the text tab is enabled in config_extended.php. Yes, the config.php file that I used to test manually enabling the setting is definitely used by phpList (it's the only file where the database credentials are set in this installation).

duncanc

11-04-18 10:07

developer   ~0060374

"because the text tab is enabled in config_extended.php"

config_extended.php isn't used at all.

The default value is set in init.php to 0 and that has not changed since 3.3.1, so this is the expected behaviour.
 The "bug" is that the value in config_extended.php is different to the default value in init.php.

michiel

11-04-18 10:33

manager   ~0060378

Yes, I second Duncan.

We can decide to enable it by default, but that's a different issue. I tried to keep the basic install as simple as possible, which means that the manual text input is suppressed and text is automatically generated. I think that's a valid decision, but I'm happy to discuss it.

samtuke

11-04-18 11:47

administrator   ~0060382

Thanks @duncanc. Yes I assumed that it was enabled by default because of the value in config_extended.php. I had tried adding the setting in config.php but had not logged out and in again it seems so the change was not applied. Defining USE_MANUAL_TEXT_PART in config.php and logging out and in via web UI does indeed apply the change. So changing the default value in config_extended.php should fix the issue.

samtuke

11-04-18 11:56

administrator   ~0060383

Fixed: https://github.com/phpList/phplist3/commit/f5f8fac7dba35e5bb32ea9c0bdd8023af5e0b335