View Issue Details

IDProjectCategoryView StatusLast Update
0019131phpList 3 applicationStatisticspublic02-05-18 10:26
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.3.2 
Target Version3.3.3Fixed in Version3.3.2 
Summary0019131: resetMessageStatistics() should remove rows from user_message_view
DescriptionThe function resetMessageStatistics() is used to remove clicks made on test messages, so that the counts of link clicks relate only to the final message sent. The function should probably remove rows from the user_message_view table because views of test messages are added to that table.

Also, the "viewed" field on the message table should probably be reset to zero because that figure does currently include views of test messages.
TagsNo tags attached.

Activities

michiel

24-03-18 08:52

manager   ~0060152


FYI @samtuke

xheni

26-04-18 15:11

administrator   ~0060479

https://github.com/phpList/phplist3/pull/298