View Issue Details

IDProjectCategoryView StatusLast Update
0019117phpList 3 applicationInterface - Administratorpublic24-05-18 20:58
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.2 
Target VersionFixed in Version3.3.3 
Summary0019117: Layout of the times of views on the Open Statistics page
DescriptionThe way that view times are displayed looks a bit clumsy with the "viewed:" label being repeated each time, and the vertical space taken up by each on its own row. I suggest having a single row with just one label.
TagsNo tags attached.

Activities

duncanc

16-03-18 17:54

developer  

view_times_before.png (22,252 bytes)
view_times_before.png (22,252 bytes)
views_times_after.png (20,267 bytes)
views_times_after.png (20,267 bytes)

duncanc

16-03-18 17:57

developer   ~0060096

Last edited: 16-03-18 17:59

View 2 revisions

Or display the view times as an additional column, which I think looks neater but might not scale down to a narrow screen.



view_times_column.png (18,641 bytes)
view_times_column.png (18,641 bytes)

michiel

17-03-18 21:54

manager   ~0060105

Yes, the last one is good.

We should convert the datatables using https://datatables.net

That will make responsiveness as simple as a single line.

samtuke

20-03-18 13:56

administrator   ~0060130

@duncanc I agree regarding the clumsiness. I had some difficulty getting the viewed times to display correctly on both the web UI and CSV output. Like Michiel your last mockup in #0060096 is my preference. Do you feel like working on that?

duncanc

20-03-18 22:01

developer   ~0060131

Last edited: 20-03-18 22:09

View 5 revisions

The view times can be joined together by < br/ > to display in a single table cell. For exporting I think the same approach of joining by comma is better than putting each view time on a separate line. But I don't really know how someone would want to use the exported data.

There are some areas of the code that I didn't understand.
1) the query at line 152 uses a group by and min/max/count when there can be only one row for a particular user/message.
2) why the result field totalcampaignviews is used on line 190
3) several tests for $totalSubscriberViews being > 1.

duncanc

21-03-18 11:13

developer   ~0060132

Last edited: 21-03-18 11:16

View 2 revisions

I think that I understand a bit more clearly now. What I suggest is to display the "total views" and "viewed" column only when the subscriber has rows in user_message_view. Displaying a value of 1 when there are no rows I think is a bit misleading.

So there would be two layouts to the results depending on whether the subscriber has viewed the campaign before or after individual views are recorded. The second result row for the gmail address is how the page looks now, when only the time of first view is recorded.



different_layouts.png (21,992 bytes)
different_layouts.png (21,992 bytes)
export_layout.png (19,651 bytes)
export_layout.png (19,651 bytes)

samtuke

21-03-18 11:26

administrator   ~0060133

@duncanc This looks like a good solution. To clarify, in cases where there is only 1 view recorded, the proposed layout for both web and CSV would be?:

address@domain.com | 21Mar 2018 09:30:30 | 2 minutes 11 seconds | 1 | 21 Mar2018 09:32:41

In other words the layout would be consistent for both single and multi view subscribers, except for additional rows / comma separated timestamps in the viewed column?

duncanc

22-03-18 06:48

developer   ~0060137

Yes, this is how the page and export look when there is only one row in user_message_view

single_view.png (10,689 bytes)
single_view.png (10,689 bytes)
single_view_export.png (8,626 bytes)
single_view_export.png (8,626 bytes)

duncanc

22-03-18 06:56

developer   ~0060138

i think that there are three combinations:

1) subscriber has viewed an old (prior to recording individual views) campaign. "total views" and "viewed" will be empty.
2) subscriber has viewed a new campaign, "total views" will be at least 1 and "viewed" will have at least one entry
3) subscriber viewed an old campaign after the recording of views started. Now "total views" and "viewed" will show the number of views since the recording started.

duncanc

22-05-18 13:29

developer   ~0060625

The code changes were included in 3.3.3 so this can be closed.

michiel

24-05-18 20:58

manager   ~0060636


FYI @samtuke @suela