View Issue Details

IDProjectCategoryView StatusLast Update
0019115phpList 3 applicationTheme - Trevelinpublic18-03-18 22:13
Reporterduncanc Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.2 
Target Version3.3.2 
Summary0019115: Trevellin theme does not display the community feed
DescriptionThe Trevellin theme now doesn't seem to display the community news feed. In release 3.3.1 it displays the news feed with 10 items on the home page, and with three items on other pages. Now it does not display any at all.

In file footer_minified.inc there are some changes

1) it tries to display the news only on the "dashboard" page but that page redirects to "home" so the code never runs
2) the code to display the news appears to have regressed. It should be using communityfeed.php, similar to dressprow, and does use that in release 3.3.1. But now it is using rssfeed.php which was replaced a while ago.

I wonder whether the correct version of the theme has been included in 3.3.2-RC2.
TagsNo tags attached.

Activities

duncanc

16-03-18 12:31

updater   ~0060093

Two changes to the theme last year with no comments on the reason for change

Display only on dashboard page
https://github.com/phpList/phplist-ui-bootlist/commit/b4088b6406c81fa17e08b2f505fad6acc72c9e79#diff-bba309d8bffdc6773069478d93243f38

and use rssfeed.php instead of communityfeed.php
https://github.com/phpList/phplist-ui-bootlist/commit/a022d4d0f17114194ccb0271ecc3d50b3287bf00#diff-bba309d8bffdc6773069478d93243f38

i think it would be sensible for all themes to use the communityfeed.php to generate the news items, as that fixed several problems with a slow response feed, and with the onyx-rss package.

user5081

16-03-18 16:41

  ~0060095

Thanks Duncan, i will investigate what happened.

user5081

18-03-18 22:13

  ~0060112

https://github.com/phpList/phplist-ui-bootlist/pull/47