View Issue Details

IDProjectCategoryView StatusLast Update
0019114phpList 3 applicationAdmin Managementpublic02-05-18 11:47
Reporterduncanc Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version3.3.2 
Target Version3.3.3Fixed in Version3.3.2 
Summary0019114: Rows in new table user_message_view should be deleted
DescriptionThere is a new table user_message_view. When a user or message is deleted then the corresponding rows in that table should also be deleted.

A user is deleted using function deleteUser() in admin/inc/userlib.php.

A message is deleted using function deleteMessage() in admin/lib.php.
TagsNo tags attached.

Relationships

duplicate of 0019116 resolvedxheni Deleting a message does not remove rows from related tables 

Activities

michiel

17-03-18 21:34

administrator   ~0060102


isn't that handled in 0019116 ?
reopen if you think it's not

michiel

17-03-18 21:35

administrator   ~0060103


ah, no, I was wrong. One is about deleting a message, the other about the user.

@samtuke, another one for xheni?

xheni

18-03-18 21:09

administrator   ~0060109

PR: https://github.com/phpList/phplist3/pull/268