View Issue Details

IDProjectCategoryView StatusLast Update
0019046phplist applicationInterface - Administratorpublic07-02-18 15:10
Reportersamtuke 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Product Version3.3.1 
Target VersionFixed in Version 
Summary0019046: Link campaign statistics from 'List campaigns' page to more detailed stats
DescriptionOn the list campaigns page (/lists/admin/?page=messages), stats such as the following are printed but not linked:

Viewed 1,753
Unique Views 1,233
total clicks 286
Bounced 581

Link these statistics to the appropriate pages which provide a more detailed breakdown of statistics. This text is likely generated by ajax and therefore the PHP script called by the ajax function is where the links will likely need to be added.
Tagsquick-fix

Activities

samtuke

16-01-18 19:17

administrator  

Selection_381.png (65,543 bytes)
Selection_381.png (65,543 bytes)

xheni

23-01-18 23:41

administrator   ~0059903

I think there is another issue on this page because the "viewed" is 0 on my side. @samtuke Can you please confirm it? I also wanted to ask to which page should we link the "Viewed" statistics because I couldn't find the appropriate page.

viewed.jpg (62,276 bytes)
viewed.jpg (62,276 bytes)

samtuke

24-01-18 11:42

administrator   ~0059905

@xheni 'Viewed' is the total views, and so should link to the mviews page for the particular campaign. That page should be accessible from campaign links from the statistics overview page. I have not checked the zero views issue, but that statistics is working correctly in the current 3.3.1 release.

xheni

31-01-18 14:46

administrator   ~0059934

PR: https://github.com/phpList/phplist3/pull/248