View Issue Details

IDProjectCategoryView StatusLast Update
0018972phpList.org[All Projects] Generalpublic21-08-18 10:34
Reporteruser5081 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Summary0018972: Can't reopen a Mantis issue
DescriptionI allways get same error (see screenshot)
TagsNo tags attached.

Activities

user5081

26-11-17 22:18

 

martin

08-01-18 08:41

administrator   ~0059792

This is normal behaviour, see:
http://mantisbt.org/bugs/view.php?id=23693&history=1

only creator or admin can reopen Resolved issues.

I could change the settings, so only if status Closed, it can't be reopened, and Resolved can. Do we want this globally set? If the cases are rare, I don't mind reopening them myself.

samtuke

08-01-18 13:13

administrator   ~0059793

@mariez It's up to you -- we can make you an admin so you can reopen them if you would like.

user5081

08-01-18 13:33

  ~0059794

In our old mantis developers and reportes used to have permission to reopen resolved issues. I think we should change settings as it was in old mantis.

user5081

21-01-18 23:38

  ~0059876

I can reopen now issues i created, but not others.
For example, i resolved this issue https://mantis.phplist.org/view.php?id=18967 created by @samtuke
but i forgot to add an example of use like this: /lists/admin/?page=help#helpCopllapseTwo,
and can't add notes to resolved issues so i need to reopen it. I can't reopen it because i am not the reporter.

martin

22-01-18 10:15

administrator   ~0059877

This option I added before:
$g_bug_readonly_status_threshold = CLOSED;
Now I added this one too, which should do the trick:
$g_update_readonly_bug_threshold = CLOSED;

There are major differences between Mantis version 1 and 2, the defaults have been changed too - that is why we experience such issues.

martin

21-08-18 10:34

administrator   ~0061027

Mariez is adminisrator now, so this should work fine in future

Issue History

Date Modified Username Field Change
26-11-17 22:18 user5081 New Issue
26-11-17 22:18 user5081 File Added: Screenshot from 2017-11-26 19-17-43.png
08-01-18 08:41 martin Note Added: 0059792
08-01-18 13:13 samtuke Note Added: 0059793
08-01-18 13:33 user5081 Note Added: 0059794
21-01-18 23:38 user5081 Note Added: 0059876
22-01-18 10:15 martin Note Added: 0059877
21-08-18 10:34 martin Status new => resolved
21-08-18 10:34 martin Resolution open => fixed
21-08-18 10:34 martin Note Added: 0061027