View Issue Details

IDProjectCategoryView StatusLast Update
0018950phplist applicationTheme - Trevelinpublic02-02-18 02:20
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Product Version3.3.1 
Target VersionFixed in Version 
Summary0018950: Improve formatting of 'Actions' section of 'List membership' page
DescriptionThis page has important functionality at the bottom in the 'Actions' section; functionality which does not exist anywhere else. However it takes up large, unnecessary screen space, and is hard to find for some users due to the need to scroll to the bottom of the page to find it.

To improve this section:

- Reduce it's size significantly by using a 2 column layout (e.g. col 1: What to do with "Tagged" subscribers:, col 2: What to do with all subscribers)
- Reduce vertical spacing between radio buttons (they are related and do not need horizontal rules or large margins)
- Reduce the whitespace at the top and bottom of the section (above 'What to do with "Tagged" subscribers:', and below 'do it')
- Reduce heading size (e.g. make 'What to do with "Tagged" subscribers:' <h4> not <h3>)
- Fix layout of dropdown menu inputs next to radio buttons (currently there is no spacing or horizontal alignment of the 'Move to' and 'Copy to' items)

Once the section has been reduced in size, and if it has become small enough, consider placing it above the 'Members' table to make it easier to find.
TagsNo tags attached.

Activities

samtuke

17-11-17 13:03

administrator  

Selection_321.png (72,099 bytes)
Selection_321.png (72,099 bytes)

mariez

02-02-18 02:20

developer   ~0059935

https://github.com/phpList/phplist3/pull/249