View Issue Details

IDProjectCategoryView StatusLast Update
0018941phpList 3 applicationBounce Managementpublic19-07-19 15:44
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.3.1 
Target Version3.3.9Fixed in Version3.3.9 
Summary0018941: Problems with the consecutive bounce processing
DescriptionA frequent question in the forums is about the consecutive bounce processing not working. I think that this commit from last year is one of the causes of people thinking it is not working
https://github.com/phpList/phplist3/commit/29790c5d6bff4154d88a4fc8add52fe4838931d1#diff-fb58aa3bbf44a7a50e2a7c85b788a752

 if (!defined('BLACKLIST_EMAIL_ON_BOUNCE')) {
     define('BLACKLIST_EMAIL_ON_BOUNCE', 5);
 }
+if ($bounce_unsubscribe_threshold < BLACKLIST_EMAIL_ON_BOUNCE) {
+ $bounce_unsubscribe_threshold = BLACKLIST_EMAIL_ON_BOUNCE;
+}
+

There are a few issues with this:

This change is modifying a config value set by the phplist admin without any warning.
The constant BLACKLIST_EMAIL_ON_BOUNCE isn't defined in either config.php or config_extended.php, so in effect no-one knows about it.
If the admin reduces the value of $bounce_unsubscribe_threshold from the default value of 5 then it is quietly set back to 5 by this change. So it will appear that the consecutive bounces processing isn't working when they expect it to be triggered after, say, two bounces.

I don't see a need for two threshold values, one is sufficient. The additional config setting could be a true/false to indicate whether the subscriber should be blacklisted in addition to being unconfirmed, by the consecutive bounce processing.

TagsNo tags attached.

Activities

duncanc

14-11-17 08:27

updater   ~0059668

Michiel, do you remember the background to adding this processing?

samtuke

25-01-19 11:36

administrator   ~0061788

@michiel This has again been raised in the forum (https://discuss.phplist.org/t/bounce-unsubscribe-threshold-not-working/3272/16)

michiel

10-02-19 18:08

manager   ~0061863

BLACKLIST_EMAIL_ON_BOUNCE will blacklist a subscriber when the threshold is reached
$bounce_unsubscribe_threshold will unsubscribe them

That's kind of it. BLACKLIST_EMAIL_ON_BOUNCE is a harder limit than bounce_unsubscribe_threshold

it looks like I put the enforcing the wrong way around.

michiel

10-02-19 18:20

manager   ~0061864


this should cover that.

https://github.com/phpList/phplist3/commit/1a2cbef9ee15545dee59df583c0b2f83aac62dfa