View Issue Details

IDProjectCategoryView StatusLast Update
0018912phpList 3 applicationTheme - Trevelinpublic18-11-17 19:08
Reportersamtuke Assigned To 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version26
Summary0018912: Styling of "import emails" page sub menu is inconsistent
DescriptionThe sub menu items on the "import emails" page (containing e.g. "copy and paste list of emails) is not styled like other page sub menus - hover on the item shows the links to be buttons with chevrons/arrow heads on the left side. Change the menu styling to be consistent with other pages.
TagsNo tags attached.

Activities

samtuke

23-10-17 12:47

administrator  

user5081

02-11-17 17:16

  ~0059623

Sorry but I dont understand. It is not a submenu, it is a list of links and has the same design as the other, check:
- /lists/admin/?page=usermgt
- /lists/admin/?page=bouncemgt
- /lists/admin/?page=system

samtuke

02-11-17 19:28

administrator   ~0059629

The purpose of the list is to provide additional navigation -- it is a menu of navigation links which is included in the page and not within the left sidebar.
The styling is shared by other similar lists, but the styling of all of these share some issues such as:

- spacing of the left angle bracket / arrow / chevron (uneven padding on top and left side
- is the angle bracket necessary at all?
- uncaptialised first word on each line (performed by CSS?)
- spacing above the list and below the preceding text ("Please choose one of the ...")

Overall these lists do not look like navigation menus, which is their purpose. Their existince as separate pages is in itself poor for usability, because it is not clear before visiting the page that they contain links to other pages, and the links cannot be found anywhere else (requiring users to know where the links are in order to use them, and requiring additional clicks to access the page with the menu before being able to visit linked pages).

Do you have ideas for improving the current situation?

user5081

03-11-17 00:17

  ~0059630

Dont worry i will find a way to improve it. I will draft on this page /lists/admin/?page=usermgt that has a list inside a list.

user5081

18-11-17 19:08

  ~0059674

commit https://github.com/mariez/phplist-ui-bootlist/commit/4058d4909e6a5c4feac61d8b992c8592f5ec210b

See sceenshots added here to view results