View Issue Details

IDProjectCategoryView StatusLast Update
0018904phpList 3 applicationGeneralpublic09-11-17 11:29
Reportersamtuke Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.2 
Summary0018904: Segment plugin: can not select value when I set "Campaign Activity" on select
DescriptionWhen I set "Campaign Activity" on Select and try to choose a value there are no available options.
That value left blank gives "one of the conditions has an Invalid target value" error message when I click calulate.

This is the case on Dressprow and Trevelin themes on phpList 3.3.2-dev (from GitHub master). Originally reported by @suela.
TagsNo tags attached.

Activities

user5081

15-10-17 23:47

 

samtuke

16-10-17 16:10

administrator   ~0059550

@suela is this because no campaign has yet been sent from that account? Please try adding a campaign and check if the problem persists.

duncanc

16-10-17 17:34

updater   ~0059551

This is a bit confusing to me, having three separate people (suela, marie and sam) all chipping in.

Initially please identify whether there is a problem with the current release of phplist, 3.3.1. If that works but the same actions do not work with 3.3.2 then you can state that.

Also, I would rather issues are raised in either GitHub or the discussion forum. Ideally the latter as often there isn't a bug but just a difference in expectations.

samtuke

17-10-17 17:12

administrator   ~0059561

@duncanc Thanks we will re-test this set of issues using phpList 3.3.1 and report back.

duncanc

18-10-17 14:07

updater   ~0059565

I have modified the plugin to display a warning on the Segment tab when no lists have been selected or when no campaigns have been sent to the selected lists. You can upgrade the plugin to version 2.2.2 on the Manage Plugins page.

samtuke

25-10-17 12:48

administrator   ~0059591

Thanks Duncan. The 'no lists selected' message now appears as in the attached screenshot.
Selection_306.png (53,546 bytes)   
Selection_306.png (53,546 bytes)   

samtuke

25-10-17 12:58

administrator   ~0059592

Extension of 'no list selected' warning text suggested on GitHub: https://github.com/bramley/phplist-plugin-segment/issues/13

samtuke

09-11-17 11:29

administrator   ~0059649

Presumed fixed in https://github.com/bramley/phplist-plugin-segment/commit/6eda522f9aab206605c34c1641d6f6f0059c548e