View Issue Details

IDProjectCategoryView StatusLast Update
0018860phpList 3 applicationInterface - Administratorpublic21-02-18 16:57
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version3.3.2Fixed in Version3.3.2 
Summary0018860: Change table name on Campaign click statistics page
DescriptionCurrently the table for stats on the Campaign click statistics page has the same name as the page. Change the first column title to reflect the contents (e.g. 'Link URL').
Tagsquick-fix

Activities

samtuke

22-09-17 17:19

administrator  

Screenshot from 2017-09-22 19-19-11.png (501,949 bytes)

samtuke

05-12-17 15:12

administrator   ~0059717

See the source code of other pages/tables which use a different table heading to first column title for how to do this. E.g. /lists/admin/?page=messages ('Campaigns' is table title, whereas 'Campaign' is first column title).

xheni

08-02-18 14:15

administrator   ~0059963

PR: https://github.com/phpList/phplist3/pull/255

xheni

08-02-18 14:18

administrator   ~0059964

@samtuke Should we add number formatting to the stats on this page as well?

samtuke

08-02-18 14:48

administrator   ~0059965

@xheni There are two versions of the mclicks page, each with different table headings. The one referenced in the PR is for an individual campaign (see screenshot attached to that issue). The changes in your screenshot relate to the other version of the page without an ID provided, which is an overview of all campaigns. In your PR, the heading refers to messages, though these are referred to as campaigns in the phpList interface (in the codebase they are sometimes still referred to as messages but that is because it is legacy code).

Therefore please do the following:

- Change 'List of available messages' to 'Clicked campaigns', and change 'Message' to 'Campaign'. These are the clearest headings I can think of.
- For the other version of the page, which includes an ID in the URL and displays individual clicks of the selected campaign, please change headings as follows: Change first column heading 'Campaign click statistics' to 'Link URL'

samtuke

08-02-18 14:49

administrator   ~0059966

Regarding number formatting: yes please add this too when convenient