View Issue Details

IDProjectCategoryView StatusLast Update
0018839phplist applicationpluginspublic07-09-17 21:46
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.3.1 
Target VersionFixed in Version3.3.2 
Summary0018839: Menu items for new plugin are added when plugin is not yet enabled
DescriptionWhen a new plugin is installed through either the automatic approach or manually copying the files, on the next page load phplist adds any menu items of the plugin to the menus even though the plugin has not yet been enabled.

See the attached screenshot for an example with the menu System > Manage Attachments

This seems to be a problem in file admin/pluginlib.php where the plugin is added to the array of enabled plugins, $plugins. Even though it is marked as not enabled

    $GLOBALS['plugins'][$className]->enabled = false;
other processing expects all entries of $plugins to be enabled.

This is only a transient problem because on the following page load the plugin is detected as disabled and not added to the array of enabled plugins.
TagsNo tags attached.

Activities

duncanc

01-09-17 09:39

developer  

plugin_menu.png (45,772 bytes)
plugin_menu.png (45,772 bytes)

michiel

07-09-17 21:46

manager   ~0059364

nice one