View Issue Details

IDProjectCategoryView StatusLast Update
0018775phplist applicationInterface - Frontendpublic18-09-17 00:37
Reportersamtuke 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version3.3.3Fixed in Version3.3.3 
Summary0018775: Public subscribe page layout improvements
DescriptionMake minor improvements to the spacing and layout of public subscribe pages.

This includes:

- Removing margin above first child headings within div.content
- Increasing line spacing of headings within div.content
- Reducing whitespace at end of div.content
- Reducing whitespace around input fields and labels
- Floating unsubscribe button to the left of the 'Subscribe to the selected newsletters' button
- Reducing whitespace to the left of 'subscribe to our selected newsletters'
button, so that it aligns with above newsletter selection checkboxes

See screenshot for reference.
TagsNo tags attached.

Activities

samtuke

14-07-17 17:54

administrator  

mariez

29-07-17 22:51

developer   ~0059268

This is done in this commit: https://github.com/mariez/phplist-ui-bootlist/commit/002f41eddca9698221956828a48940d1ed50bdef

I cant position "unsubscribe" link beside the subscribe button, because the link is outside the entire form. This will require a change in the application that i prefer not to do, because will affect other themes. But i remove the breaks and aligned the link to the right. hope this suite your need.

samtuke

31-07-17 12:06

administrator   ~0059275

The page is now greatly improved. Please test moving the unsubscribe link in the core application code, and review its appearance on Dressprow also. Screenshot of the current layout of this link in mobile view using Trevelin is attached.

samtuke

31-07-17 12:07

administrator  

mariez

07-08-17 05:01

developer   ~0059289

done in this pr. https://github.com/phpList/phplist3/pull/191

samtuke

07-08-17 13:37

administrator   ~0059291

The subscribe links are much better now. Please also reduce the whitespace between the fields (e.g. the text input and other fields - see screenshot)

samtuke

07-08-17 13:38

administrator  

mariez

18-09-17 00:37

developer   ~0059395

https://github.com/mariez/phplist-ui-bootlist/commit/d0730a728bf6bec892d818d23b43be6480728e1f