View Issue Details

IDProjectCategoryView StatusLast Update
0018706phplist applicationMessage Managementpublic15-05-17 15:48
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.3.1 
Target Versionnext patchFixed in Version 
Summary0018706: Repeat message processing tries to copy an index
DescriptionWhen repeating a message there is an sql error reported in the event log

Database error: Unknown column 'index_1' in 'field list'

This seems to be caused by the use of $DBstruct which lists the columns of each table but also the indices (index_1 in this case). The code in function repeatMessage() in file admin/connect.php tries to copy all the columns of the message table except some specific ones, and so tries to copy a column named index_1.

The index was added to the message table as part of the introduction of UUID fields

https://github.com/phpList/phplist3/commit/6956ff33d08bad69e52d502fbf271f5db565c8d4
TagsNo tags attached.

Activities

duncanc

05-05-17 11:02

developer   ~0059022

See pull request https://github.com/phpList/phplist3/pull/174