View Issue Details

IDProjectCategoryView StatusLast Update
0018609phpList 3 applicationBrowser Issuespublic22-08-18 16:35
Reporterjeroenwervel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.1 
Target VersionFixed in Version 
Summary0018609: browser error when forwarding message
Descriptionhttp://www.wervel.be/lists/?p=forward&mid=262&uid=8d1cb94442ef2becde56dbdd72379e03&utm_source=phplist262&utm_medium=email&utm_content=HTML&utm_campaign=Molendag+graan+28+mei+Galmaarden+%2F+Training+week+agroecology+8-12+May+near+Huy

Sorry a software error occurred:
Please report a bug when reporting the bug, please include URL and the entire content of this page.

Notice: Undefined index: uniqid in /data/sites/web/wervelbe/www/lists/admin/plugins/SubscribersPlugin.php on line 190
phpList version 3.3.1
Wervel - Werkgroep voor Rechtvaardige en Verantwoorde Landbouw vzw
Forwarding the message with subject Molendag graan 28 mei Galmaarden / Training week agroecology 8-12 May near Huy

alain.peeters@rhea-environment.org: The message has been forwarded
TagsNo tags attached.

Activities

duncanc

31-03-17 09:59

updater   ~0058937

This is a problem with the Subscribers plugin, not with phplist itself.

Problems with specific plugins are probably better reported on either the user forum https://discuss.phplist.org/ or on the plugin's GitHub repository.

But the problem here is due to the plugin looking to replace some placeholders e.g. [LISTSUBSCRIBE], which apply only to a subscriber, not to the person to whom the email is being forwarded. In the latter case a variable does not exist, causing the error you saw.

By the look of it, the email was forwarded successfully. But it should be straightforward for me to change the plugin so that the error is avoided.

duncanc

01-04-17 07:26

updater   ~0058941

I have fixed the problem so you can now upgrade the Subscribers plugin on the Manage Plugins page.