View Issue Details

IDProjectCategoryView StatusLast Update
0018595phplist applicationSubscriber Importpublic06-07-17 20:13
Reporterth 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSCentOSOS Version6.8
Product Version3.3.1 
Target VersionFixed in Version3.3.2 
Summary0018595: Users attributes wasn't updated when importing CSV
DescriptionI want to submit a CSV file with updated users informations and/or adding new users. I use custom attributes.
Processing the CSV file do not replace/update value of attributes if user already exists in DB (problem is here).
For new users attributes are filled with CSV values (work as expected).

(Using phpList upgraded from 3.2.7 to 3.3.1)

Same report in #3 from https://discuss.phplist.org/t/importing-subscribers-from-file-errors/2616
Additional InformationCan't find similar bug reported. Hope it's not a duplicate.
TagsNo tags attached.

Activities

duncanc

23-03-17 18:32

developer   ~0058914

I cannot repeat the problem so I guess that there is something unusual about the content of your import file. For example, does it have any accented characters?

When you view the Test Output, which lists the first few subscribers, does that match correctly the attribute name with the attribute value for the subscribers?

th

24-03-17 09:39

reporter   ~0058922

My sample file is minimalist (2 entries) and does not contain special or accented chars.

But i found that the problem only occurs in new theme "Trevellin".

From "import subscribers from csv file" with "Test output" checked :
In "Dressprow" theme i've the "summary" table with "Test output" preview and "confirm import" button. When i continue, attributes value will be correctly updated.
In "Trevellin" i can't have the intermediate page for summary/preview but land directly to the result import screen with message "Importing 2 subscribers to 1 lists, please wait"

Another test :
Start with "Dressprow" theme, begin import to the summary screen and pause here.
From settings i switch to the "Trevellin" theme.
When i return to "import subscribers from csv file", the summary page will correctly be displayed in "Trevellin" theme. I can click the "confirm import" button and the import works as expected.

I can provide you more informations or do some screenshots if needed.

duncanc

24-03-17 12:30

developer   ~0058925

I can repeat the problem now with the Trevelin theme. The test output page is not displayed at all, and there are some javascript errors reported in the browser console.

samtuke

24-03-17 14:38

administrator   ~0058926

Can you look into this Marie?

mariez

31-03-17 23:01

developer   ~0058940

The checkboxes on that form wasnt submiting at all. I removed the script styling the element and now the "test output" is working.
This is the commit: https://github.com/mariez/phplist-ui-bootlist/commit/282341f2e01f7809d66b27445b984e700ec477d9

Please tell me if the bug you detect is resolved.

And if you can, test the radio buttons because the have a similar script overwriting the element.

Thanks a lot for you help.

duncanc

19-04-17 09:48

developer   ~0058976

Last edited: 19-04-17 10:09

View 2 revisions

Marie, yes, the import problem is fixed with this change.
But there are some javascript errors reported in the firefox web console, see screenshot.

Whereabouts are radio buttons used that are affected by the new theme?

duncanc

19-04-17 10:10

developer  

mariez

24-04-17 16:23

developer   ~0059005

Last edited: 24-04-17 16:39

View 3 revisions

I only see the first js error (progressmeter). Not the errors you have (type errors because of "parentJQuery"). See attached image.
I will investigate if this is related to a plugin.

I have radio buttons, for example, on:
Import emails > Import by uploading a file with emails
I see an item there named "rssfrequency" with ratio buttons to choose.
url: /lists/admin/?page=import1

mariez

24-04-17 16:33

developer  

mariez

24-04-17 18:46

developer   ~0059008

duncanc, i cant reproduce the javascript type erros you have.
I tested in Firefox an Chrome on an installation with Trevelin theme and these plugins enabled:

- BounceStatisticsPlugin
- CKEditorPlugin
- CommonPlugin
- debugaid
- MessageStatisticsPlugin
- restapi
- restapi2
- restapi_test
- RssFeedPlugin
- rssmanager
- SegmentPlugin

Can you give me some information about your installation.

duncanc

24-04-17 19:47

developer   ~0059009

Last edited: 24-04-17 20:05

View 2 revisions

The error regarding progressmeter still occurs. That is used in line 42 of file actions/import2.php

        echo '<script language="Javascript" type="text/javascript"> document.write(progressmeter); start();</script>';

From what I can see there isn't a variable named progressmeter, only a div with an id of progressmeter.
But this doesn't look to be related to any changes that you have made.

I do not see the errors about "updateProgress not a function" now.

mariez

25-04-17 00:19

developer   ~0059013

Last edited: 25-04-17 00:21

View 2 revisions

That error is in pages with progressbar, i didnt find a way to fix that. The reason:
That call to progressmeter is in a .js file of phpList application. It is related to jquery-ui progressbar. If i remove it, dressprow progressbar will not work, i think, so i cant remove it. But Bootstrap themes don't use jQuery-ui, so bootstrap themes dont find the progressmeter reference.

julienl

08-06-17 17:25

reporter   ~0059168

Same here with. If i switch to the "old" template, it works.

mariez

06-07-17 20:02

developer   ~0059213

As i wrote in this note:
https://mantis.phplist.org/view.php?id=18595#c58940

this was resolved in this commit:
https://github.com/mariez/phplist-ui-bootlist/commit/282341f2e01f7809d66b27445b984e700ec477d9

samtuke

06-07-17 20:13

administrator   ~0059214

@julienl this issue should be fixed in the upcoming phpList 3.3.2 release. You can test it via the current Git Master branch on Github, or test a release candidate of 3.3.2 which will be released within the next few weeks.