View Issue Details

IDProjectCategoryView StatusLast Update
0018526phplist applicationAll Otherpublic12-02-17 12:27
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.3.1-RC1 
Target VersionFixed in Version3.3.1 
Summary0018526: The asynchronous statistics pages do not seem to work with minified assets
DescriptionA problem reported in the user forums with 3.3.1-RC1. The Stats Overview page does not display anything, nor do the View Opens or Campaign Click Statistics pages.

After changing minified assets to false in config.php the pages are displayed.
define('USE_MINIFIED_ASSETS', false);

See https://discuss.phplist.org/t/stats-overview-not-showing-in-phplist-3-3-1-rc1/2548
TagsNo tags attached.

Activities

michiel

11-02-17 22:22

manager   ~0058777

I'll need more than that. I have minified on, and it shows fine.

duncanc

11-02-17 22:28

developer   ~0058778

Last edited: 12-02-17 12:25

View 2 revisions

Seems to be a problem only with the "phplist default" theme when minified assets are used. For the two other themes, the pages do display with minified assets.

It appears that the all.js and all.min.js files for the default theme have not been regenerated to include the correct version of phplistapp.js.

michiel

12-02-17 12:27

manager   ~0058779

Ok, reminified the CSS and JS on the default theme. I've also hidden the default theme, when there are other themes.

The default theme was a snapshot of dressprow. The idea was that it allowed checking out the core code without needing to install a theme as well for the basics to work. So, it's more there for DEVs.