View Issue Details

IDProjectCategoryView StatusLast Update
0018524phplist applicationAll Otherpublic12-02-17 12:34
Reporterduncanc 
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.1-RC1 
Target Version3.3.1Fixed in Version3.3.1 
Summary0018524: Comments on 3.3.1-RC1
DescriptionIn file actions/processqueue there is an error in the assignment of uuids for messages. The code actually updates the user table instead.

When there are more than 400 subscribers then the upgrade process delays assigning uuids for subscribers until the next run of process queue. I think it would be helpful to display a message explaining that.
TagsNo tags attached.

Activities

alexei

09-02-17 14:37

reporter   ~0058763

On this line
https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/actions/processqueue.php#L83
It asks for where uuid is not set, but on this line
https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/actions/processqueue.php#L89
It's actually changing uniqid, which on the next run it goes through all of the subscribers (we have like 35K) again
The same story with these lines:
https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/actions/processqueue.php#L93
https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/actions/processqueue.php#L98
Processing all of our subscribers takes ~30min every time the query submit runs, this is why query processing looks like it get stuck.

alexei

09-02-17 14:40

reporter   ~0058764

So the solution is to change uniqid to uuid in the DB update calls.
This is also messed up uniqid in our DB since it was regenerating it all the time.
So I would say this is not a minor bug

duncanc

09-02-17 14:51

developer   ~0058765

You appear to be looking at an old version of the code. If you download 3.3.1-RC1 then some of this will have been fixed. But there is still a problem with assigning UUIDs to messages, which might have an effect by changing the UUID of some subscribers.

alexei

09-02-17 15:30

reporter   ~0058766

The bug is in https://sourceforge.net/projects/phplist/files/phplist/3.3.0/phplist-3.3.0.tgz/download Which is supposed to be stable.

alexei

09-02-17 15:33

reporter   ~0058767

So it needs to be fixed with new stable release ASAP. Thanks for looking into it.

samtuke

09-02-17 15:40

administrator   ~0058768

> The bug is in https://sourceforge.net/projects/phplist/files/phplist/3.3.0/phplist-3.3.0.tgz/download [^] Which is supposed to be stable.

See here for the latest version: https://sourceforge.net/projects/phplist/files/phplist-development/3.3.1-RC1/

alexei

09-02-17 16:19

reporter   ~0058769

Would you mind posting here: https://www.phplist.org/newslist that version 3.3.0 was recalled and one should revert back to 3.2.7 as described here https://sourceforge.net/projects/phplist/files/phplist/3.3.0/. So that everybody who downloaded 3.3.0 are aware of the situation.
Thanks

samtuke

10-02-17 19:24

administrator   ~0058770

From the forum (https://discuss.phplist.org/t/phplist-3-3-0-fast-but-will-not-process-que/2509/6):

> Some progress. New campaign will process queue to an extent. I have set the batch size to 120 and the time to 60 seconds. phpList 3.3.1-RC1 will process 120 addresses then freeze after about 40 seconds. Resume processing button does not work unless I wait several minutes. Upper frame in Send Queue window does have progress text but not lower window...

samtuke

10-02-17 19:33

administrator   ~0058771

@alexei Thanks for the suggestion. That list is reserved for new release announcements and is distributed widely, so it's not a good place for such a statement.

michiel

10-02-17 21:11

manager   ~0058772

This issue seems to have diverted but the original issue was fixed here
https://github.com/phpList/phplist3/commit/a1e55a490e67105a33c48c7a288862b35610a737

However, that does not address "I think it would be helpful to display a message explaining that."

I will add something for that, as I agree.

duncanc

10-02-17 22:17

developer   ~0058773

Michiel, you are still missing it. In actions/processqueue.php line 98 is updating the wrong table.

michiel

10-02-17 22:32

manager   ~0058774

ah, yes, now I see it, thanks