View Issue Details

IDProjectCategoryView StatusLast Update
0018513phpList 3 applicationphpListpublic25-06-18 10:10
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version3.3.1 
Target Version3.3.4Fixed in Version 
Summary0018513: Don't count test message opens as campaign views
DescriptionCurrently phpList counts views of test messages as contributing to the total of the views of the campaign that it relates to. This can cause statistics, especially of smaller campaigns which are tested extensively, to be inaccurate. Do not count views of test messages towards the campaign view totals.
TagsNo tags attached.

Activities

michiel

03-02-17 07:51

manager   ~0058719

That's what the checkbox "Reset click statistics" does.

samtuke

17-01-18 15:15

administrator   ~0059852

The 'Reset click statistics' checkbox does not result in click stats being reset. Views and opens are unchanged from accumulated test messages when the campaign is queued.

michiel

11-06-18 22:30

manager   ~0060717

can you give some evidence of that statement?

duncanc

24-06-18 07:15

updater   ~0060771

The viewed count for a message was not reset to 0 until this recent change

https://github.com/phpList/phplist3/commit/3f63deb3971ccc50d01be2a411bbe64f01970bc7#diff-6148ebc39f07746cc491cfe52b1b9981

There is also a constant RESETSTATS_MAX that seems to guard against resetting stats after a campaign has been sent for real.

duncanc

24-06-18 07:18

updater   ~0060772

Actually that change had an error that was not fixed until

https://github.com/phpList/phplist3/commit/6f64faf14ba284586647a1e0a61822cb7e114376#diff-6148ebc39f07746cc491cfe52b1b9981

so has not yet been included in a release.

samtuke

25-06-18 10:09

administrator   ~0060778

Thanks @duncanc. Looks like this is already scheduled for phpList 3.3.4.