View Issue Details

IDProjectCategoryView StatusLast Update
0018510phplist applicationTheme - bootstrappublic15-05-17 10:40
Reportersuela 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.1 
Target VersionFixed in Version 
Summary0018510: Lists not displaying when importing subscribers.
Description When importing subscribers there is no "Lists" displayed to add them to.
The subscribers are imported but they are not added to any list.

http://thinkingfree.org/pl33rc4/admin/?page=import1

Screenshot included.
TagsNo tags attached.

Relationships

related to 0018501 resolvedmariez 'Send a campaign' page does not show lists by default in mobile view 
related to 0018540 closedsupport lists tab not working while composing message with bootlist theme 

Activities

suela

01-02-17 17:16

manager  

ListsNotDisplaying.JPG (115,667 bytes)
ListsNotDisplaying.JPG (115,667 bytes)

mariez

01-02-17 19:47

developer   ~0058715

I think this should be resolved with last commit, but i am not sure because your screenshot is desktop view.

The change has been applied on test site, so if you can access please test here:
https://phplist.hosted.phplist.com/lists/admin/?page=import1

duncanc

06-03-17 12:12

developer   ~0058848

This problem is not fixed in release 3.3.1, see the additional screenshot.

duncanc

06-03-17 12:12

developer  

import no lists shown.png (15,986 bytes)
import no lists shown.png (15,986 bytes)

samtuke

08-03-17 17:35

administrator   ~0058854

See also https://discuss.phplist.org/t/3-3-1-step-5-list-empty/2664/3

mariez

08-03-17 21:17

developer  

mariez

08-03-17 21:20

developer  

mariez

08-03-17 21:24

developer   ~0058855

Hi, Duncan. I checked my local installation on a desktop Firefox and on a mobile Chrome and is working ok on both (see attached images).
The only thing that I guess could be happening is that maybe the Trevelin theme is not updated when you update the application. Because the bug (and the fix) are on theme side, if you updated the application but not the theme directory the bug will be still there. Can you replace the /list/admin/ui/phplist-ui-bootlist directory with the same directory included in the package: https://sourceforge.net/projects/phplist/files/phplist/3.3.1/phplist-3.3.1.tgz and see if that works?

duncanc

08-03-17 21:59

developer   ~0058856

It seems to be something to do with categories. I have four lists but none categorised, and had the problem with display.

As a test, I added one list to a category and now the lists are displayed for importing. See the new screenshot.

duncanc

08-03-17 21:59

developer  

mariez

08-03-17 22:06

developer   ~0058857

Thanks duncan, that is very usefull information. seem this need more work.

mariez

09-03-17 19:44

developer   ~0058866

This should be fixed in this commit:
https://github.com/mariez/phplist-ui-bootlist/commit/f0e81c18a454ce249ee31a85148405461524d01d

Thanks for all your help, duncanc.