phplist

NOTE:: Before reporting an issue, make sure you are running the latest version, currently 3.3.1


View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0018510phplist applicationTheme - bootstrappublic01-02-17 17:1609-03-17 19:44
Reportersuela 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version3.3.1 
Target VersionFixed in Version 
Summary0018510: Lists not displaying when importing subscribers.
Description When importing subscribers there is no "Lists" displayed to add them to.
The subscribers are imported but they are not added to any list.

http://thinkingfree.org/pl33rc4/admin/?page=import1 [^]

Screenshot included.
TagsNo tags attached.
Attached Filesjpg file icon ListsNotDisplaying.JPG [^] (115,667 bytes) 01-02-17 17:16


png file icon import no lists shown.png [^] (15,986 bytes) 06-03-17 12:12


png file icon Screenshot_20170308-165657.png [^] (77,491 bytes) 08-03-17 21:17


png file icon Screenshot from 2017-03-08 18-19-29.png [^] (131,147 bytes) 08-03-17 21:20


png file icon list import with categories.png [^] (22,844 bytes) 08-03-17 21:59

- Relationships Relation Graph ] Dependency Graph ]
related to 0018501resolvedmariez 'Send a campaign' page does not show lists by default in mobile view 

-  Notes
(0058715)
mariez (developer)
01-02-17 19:47

I think this should be resolved with last commit, but i am not sure because your screenshot is desktop view.

The change has been applied on test site, so if you can access please test here:
https://phplist.hosted.phplist.com/lists/admin/?page=import1 [^]
(0058848)
duncanc (developer)
06-03-17 12:12

This problem is not fixed in release 3.3.1, see the additional screenshot.
(0058854)
samtuke (administrator)
08-03-17 17:35

See also https://discuss.phplist.org/t/3-3-1-step-5-list-empty/2664/3 [^]
(0058855)
mariez (developer)
08-03-17 21:24

Hi, Duncan. I checked my local installation on a desktop Firefox and on a mobile Chrome and is working ok on both (see attached images).
The only thing that I guess could be happening is that maybe the Trevelin theme is not updated when you update the application. Because the bug (and the fix) are on theme side, if you updated the application but not the theme directory the bug will be still there. Can you replace the /list/admin/ui/phplist-ui-bootlist directory with the same directory included in the package: https://sourceforge.net/projects/phplist/files/phplist/3.3.1/phplist-3.3.1.tgz [^] and see if that works?
(0058856)
duncanc (developer)
08-03-17 21:59

It seems to be something to do with categories. I have four lists but none categorised, and had the problem with display.

As a test, I added one list to a category and now the lists are displayed for importing. See the new screenshot.
(0058857)
mariez (developer)
08-03-17 22:06

Thanks duncan, that is very usefull information. seem this need more work.
(0058866)
mariez (developer)
09-03-17 19:44

This should be fixed in this commit:
https://github.com/mariez/phplist-ui-bootlist/commit/f0e81c18a454ce249ee31a85148405461524d01d [^]

Thanks for all your help, duncanc.


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker