View Issue Details

IDProjectCategoryView StatusLast Update
0018501phplist applicationTheme - bootstrappublic19-07-17 15:53
Reportersamtuke 
PriorityhighSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.0 
Target Version3.3.2Fixed in Version 
Summary0018501: 'Send a campaign' page does not show lists by default in mobile view
DescriptionWhen using some smaller viewport sizes, the available mailing lists on the 'Lists' tab are not displayed by default. The viewport needs to be resized to make the smaller tabs containing available lists appear (e.g. uncategorised tab etc.). See screenshot.
TagsNo tags attached.

Relationships

has duplicate 0018540 closedsupport lists tab not working while composing message with bootlist theme 
related to 0018507 resolvedmichiel nothing loads with "use minified assets" = false 
related to 0018510 resolvedmariez Lists not displaying when importing subscribers. 

Activities

samtuke

27-01-17 18:10

administrator  

samtuke

30-01-17 18:50

administrator   ~0058703

This problem is also affecting usage on desktop. Currently testing phpList 3.3 RC4 and on the lists page no lists are displayed even when the link ("Please select the lists you want to send your campaign to") is clicked. The available lists are all visible in the site source code however.

samtuke

30-01-17 18:51

administrator  

Screenshot from 2017-01-30 19-27-55.png (794,877 bytes)

samtuke

01-02-17 10:36

administrator   ~0058707

This problem has been replicated by two other users and is now a blocking issue.

mariez

01-02-17 15:20

developer   ~0058710

Yes i'm working on it. The problem is on mobile, not desktop. It only affect desktop screens, if you start the page on mobile view (window smaller than 768px), then click on the link "Please select the lists you want to send your campaign to", and then resize your browser to desktop.

mariez

01-02-17 17:58

developer   ~0058711

THis commit
https://github.com/mariez/phplist-ui-bootlist/commit/1d17efb9c6fae3baa7fc2ccff76a6295161dd520

resoved this problem and its related issues, turning off the scritp that switch tabs to accordion on mobile view. That script is the problem.

I will work now in a resporsive design for tabs. Maybe doing the same but with a custom script, not tabCollapse. I think our "injection" method of bootstrap styles is not compatible with tabCollapse script.

samtuke

01-02-17 18:13

administrator   ~0058712

Should this issue be marked resolved then?

mariez

01-02-17 19:16

developer   ~0058713

Yes, i will add a new one with normal priority for the pending work related.

samtuke

06-02-17 14:43

administrator   ~0058748

Related: https://discuss.phplist.org/t/new-theme-trevelin/2511