View Issue Details

IDProjectCategoryView StatusLast Update
0018453phplist applicationInterface - Administratorpublic17-12-16 17:33
Reportersamtuke 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.6 
Target VersionFixed in Version3.3.0 
Summary0018453: Tab content titles made lower case on send campaign page due to interfacelib
Descriptionline 828 of lib/interfacelib.php includes the following function which makes text lowercase:

    public function setCurrent($name)
    {
        $this->current = mb_strtolower($name);
    }

This results in the titles of all tab contents on the send campaign page lower case (e.g. the "Content" tab becomes "content") regardless of the translation text capitalisation.

Is this lowercase function necessary? It would be better if the tab content titles were captialised.
TagsNo tags attached.

Activities

michiel

17-12-16 15:51

manager   ~0058556

I can't remember the reason. I think the lib should not touch the texts at all, except for page rendering, eg htmlspecialchars

michiel

17-12-16 17:32

manager   ~0058558

Ah, the reason is the test on line 905

I'll use a new variable to manage this, so that it doesn't touch the value of current.