View Issue Details

IDProjectCategoryView StatusLast Update
0018437phpList 3 applicationInterface - Administratorpublic20-04-18 15:19
Reporterduncanc Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.6 
Target Version3.3.2 
Summary0018437: The domain stats page is still confusing
DescriptionI know that work has been done on the domain stats page but the results shown are still a bit muddled.

1) The "top 50 domains" table has gaps, see the screenshot. The gaps are caused by there being two queries, the top 50 confirmed, and the top 50 unconfirmed, then trying to merge the results. A gap appears when a domain is in the top 50 confirmed but not in the top 50 unconfirmed.
It is clearer to have just one query that derives totals of confirmed, unconfirmed, and blacklisted.

2) Displaying percentages is inconsistent. In the "top 50" table the % is of the total number of subscribers. But note that some comments in the code refer to "as a percentage of all subs on this domain".
But in the "Domains with most unconfirmed subscribers" table the % is of the total subscribers for that domain, except for the total column which is of all subscribers.

3) As a subscriber can be both confirmed and blacklisted, or unconfirmed and blacklisted, showing just confirmed and unconfirmed counts can be misleading. The confirmed count need not be the number of subscribers who will be sent a campaign, because some might be blacklisted. I suggest displaying three columns, using these rules that are used on the Lists page

confirmed = confirmed and not blacklisted
unconfirmed = not confirmed and not blacklisted
blacklisted = blacklisted

4) When using group by in a query the having clause can be used to filter the grouped results. The code for "Domains with most unconfirmed subscribers" has some convoluted php code to select only the result rows that have > 0 unconfirmed. That is simply achieved by adding

    having unconfirmed > 0
to the query.


TagsNo tags attached.

Activities

duncanc

07-12-16 11:20

updater  

domainstats.png (43,309 bytes)   
domainstats.png (43,309 bytes)   

duncanc

07-12-16 11:23

updater  

new domainstats layout.png (34,227 bytes)   
new domainstats layout.png (34,227 bytes)   

duncanc

07-12-16 11:25

updater   ~0058525

I have changes for most of these points but not sure what to do about displaying percentages. Whether they should be of all subscribers, or only subscribers on the domain.
see the second screenshot for the modified table layout.

support

09-05-17 21:50

administrator   ~0059033


If you have this ready in a PR, that would be great. I guess percentage wise, it'll be best to use percentage of total subscribers. That will make things much clearer. At the moment, it is percentage of subscribers in that domain iirc.

duncanc

13-05-17 12:18

updater   ~0059063

See https://github.com/phpList/phplist3/pull/176