View Issue Details

IDProjectCategoryView StatusLast Update
0018379phpList 3 applicationInterface - Backendpublic27-10-16 21:09
Reporterehuggett 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.2.5 
Target VersionFixed in Version 
Summary0018379: "phpList community news" in dressprow theme causing page load delays
DescriptionThe "phpList community news" section shown in the dressprow theme on many backend pages loads (server side) an RSS feed from https://www.phplist.org/newslist/feed/

When www.phplist.org is slow to respond, page load times are increased significantly.

It seems the content is cached in, by default, /tmp/phplistnews.

The time for a request without the cache file varies, based upon the response time for php, but was frequently taking > 5 seconds at the time i observed this.

A request for the index file of domain.com/lists/admin/ takes 1-1.5 seconds with the cache populated.

When line 17 of public_html/lists/admin/ui/dressprow/rssfeed.php is replaced with

"$parseresult = FALSE;"

Requests for the index file are around 30ms, about 80x faster.
Steps To Reproduce1. Using browsers development tools, load and refresh https://your-domain.com/lists/admin/ observing the request time for the index file (ignore other files)

2. delete /tmp/phplistnews, repeat step 1

3. Modify line 17 of public_html/lists/admin/ui/dressprow/rssfeed.php as detailed above, repeat step 1
Additional InformationThe files in the dressprow github repo don't seem to match what was included in the 3.2.5 release? perhaps this is already fixed.
TagsNo tags attached.

Relationships

duplicate of 0018128 resolvedmichiel Community news sidebar causes delay on loading every page 

Activities

michiel

27-10-16 21:09

manager   ~0058410

already handled in 0018128