View Issue Details

IDProjectCategoryView StatusLast Update
0018347phplist applicationConfigurationpublic11-05-17 19:49
Reporterebonweaver 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu 14 ServerOS Version14.04.5
Product Version3.2.5 
Target Versionnext minorFixed in Version3.3.2 
Summary0018347: Pageroot does not change root in all ways
DescriptionIf you want to run phplist as the only site on a server, so putting it in /lists makes no sense, you change $pageroot = '/lists'; in the config file to be $pageroot = '/';
However, that only changes a portion of the default root directory functionality. You then must manually change every single subscription settings option in the Dashboard -> Configure screen. This should not be required, and is not in your documentation. The point of a system setting is to apply to the system. It is now unknown if we'll find other issues due to similar variables not tied to this pageroot setting as they should be.
Steps To ReproduceAs stated, set your apache webroot to the directory you have phplist in.
chage pageroot to /
Go to the site home page and click the subscribe link
hey look, an error saying /lists/ can't be found! Well why is it looking for that??
TagsNo tags attached.

Activities

support

10-05-17 21:57

administrator   ~0059047


You should set that value before the first installation, and it should all work fine. Changing it retrospectively can cause issues, that's true.

Might be good to check if that can be changed.

michiel

11-05-17 19:49

manager   ~0059054

added a warning in config_extended about this.