View Issue Details

IDProjectCategoryView StatusLast Update
0018240phplist applicationInterface - Administratorpublic15-05-17 15:10
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.2.5 
Target Versionnext minorFixed in Version 
Summary0018240: Lists to exclude area not displayed correctly
DescriptionWhen USE_LIST_EXCLUDE is enabled, the area on the Lists tab is not always displayed correctly as the checkboxes are missing. See the attached screen shot.

This seems to be caused by two factors. When there are fewer than 5 lists and no categories defined then the processing tries to display not using tabs. See functions listSelectHTML() and ListofLists() in file connect.php.

When there are more than 5 lists or at least one list is assigned to a category then the area is displayed with tabs and checkboxes. See the second screenshot.

TagsNo tags attached.

Activities

duncanc

25-07-16 07:53

developer  

exclude_lists.png (32,593 bytes)
exclude_lists.png (32,593 bytes)

duncanc

25-07-16 07:57

developer  

exclude_lists_ok.png (29,561 bytes)
exclude_lists_ok.png (29,561 bytes)

gingerling

25-07-16 10:05

manager   ~0058035

Is this something that you will take a look at or should I assign it to the UI people?

duncanc

25-07-16 12:52

developer   ~0058043

Probably Michiel needs to look at it.

gingerling

25-07-16 16:52

manager   ~0058050

ok, cool

michiel

07-05-17 11:24

manager   ~0059024


This would be good to sort out, for a new release

mariez

07-05-17 15:13

developer   ~0059025

Last edited: 07-05-17 15:14

View 2 revisions

Similar problem was on Trevelin theme. It is fixed there. It is related to javascript rewriting form elements inside tabs that are inside accordion. I will take a look this tuesday.

mariez

08-05-17 14:43

developer   ~0059026

I took a look at this, and it is not a javascript problem. Tabs are not there, i guess, because of a choise of the developer, when there are no categories and less than 5 lists to show.

About checkboxes: I see checkboxes. They are not styled but they are present and you can check them as usual. I tested in Firefox, Chrome and Opera. (see attached images) maybe you are using a different browser?

mariez

08-05-17 14:43

developer  

mariez

08-05-17 14:43

developer  

mariez

08-05-17 14:44

developer  

mariez

08-05-17 14:50

developer   ~0059027

I see the bug, it happens when you select a list, go to other tab, and go back to Lists tab. will check.

mariez

09-05-17 23:39

developer   ~0059035

PR: https://github.com/phpList/phplist3/pull/175