View Issue Details

IDProjectCategoryView StatusLast Update
0018196phpList 3 applicationGeneralpublic10-05-17 21:52
Reportergingerling Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Summary0018196: Campaign not sent to subscriber who was blacklisted then unblacklisted while a member of list
DescriptionIf a subscriber is on one or more lists when they are blacklisted, if they are later unblacklisted they will not receive campaigns sent to any of the lists they were on at the time they were blacklisted.
Steps To Reproduce1) Add a subscriber to a list
2) Blacklist the subscriber
3) send a campaign to that list
4) unblacklist the subscriber
5) re-queue the mail
6) campaign is not sent to the subscriber

1) Add subscriber to a list
2) blacklist the subscriber
3) unblacklist the subscriber
4) create a new campaign
5) send it: it will not go to the new subscriber
Additional InformationMail IS sent when:

subscriber is blacklisted and NOT on the sending list at the time, so

1) Blacklist a subscriber
2) unblacklist them
3) add them to the list
4) send a campaign to the list
5) the campaign is sent.
TagsNo tags attached.

Activities

gingerling

18-07-16 15:02

manager   ~0057982

Did not happen when I was testing the invite plugin today, so suggest that the method of blacklisting an unblacklisting is relevant.

gingerling

18-07-16 16:45

manager   ~0057985

1) made list "blacklist test 2" made it public
2) added anna@phplist.com to the list
3) sent campaign
4) clicked unsubscribe
5) re-subscribe, specifically checking the blacklist test 2 list
6) subscriber remains blacklisted till clicking confirmation email.
(6b - message on confirm page says "We already received your confirmation previously")
7) checked subscriber not blacklisted and is on the blacklist test 2 list
8) send campaign to list
9) mail WAS received


1) went to anna@phplist.com profile and clicked add to blacklist
2) went into history > subscription and removed from blacklist, checked and is not longer blacklisted, and is on list
3) mail sent and received

1) added new subscriber blaklisttest@dispostable.com
2) sent campaign by re-queueing old campaign - received
3) clicked add to blacklist button
4) clicked remove from blacklist,
5) sent mail, worked.

So essentially I can't replicate this today at all. I tested is very completely the last time, so i don't know what the issue is now.

samtuke

18-07-16 17:43

administrator   ~0057987

Anna: Do you have proposed next steps for this issue at this time?

gingerling

18-07-16 18:06

manager   ~0057988

I will just leave it open and test it now and then to see if I can replicate. If not I will close.