View Issue Details

IDProjectCategoryView StatusLast Update
0018151phpList 3 applicationGeneralpublic11-05-17 20:30
Reportergingerling Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Summary0018151: List ownership not displayed (so not editable) when primary admin owns the list.
DescriptionWhen a sub-admin owns a list, the primary admin can edit this - by clicking edit on the list page, they can see the currnt list owner and can select another sub-admin to be the owner using a dropdown menu.

However, if the primary admin itself owns a list, there is no dropdown displayed. This means that while they can guess that they own the list (though it's a bit cryptic) they can't give the list to another admin.

I think that the drop-down should show for all admins, including the main admin.
TagsNo tags attached.

Activities

michiel

20-06-16 12:57

administrator   ~0057797

No, the dropdown will appear it there are more than one admin. If there's only one, it won't show.

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/editlist.php#L154

gingerling

20-06-16 13:14

manager   ~0057800

Yes I see, the confusion was/is caused by a VPS account who is supposed to have lots of subaccounts, but we cant check as that is in admin area. Are sub accounts listed anywhere else?