View Issue Details

IDProjectCategoryView StatusLast Update
0018113phplist applicationphpListpublic04-01-18 15:30
Status resolvedResolutionunable to reproduce 
Platformn/aOSn/aOS Version
Product Version3.2.4 
Target Version3.3.2Fixed in Version3.3.2 
Summary0018113: Subscriber page nr in database changes after sending message
DescriptionI use several subscriber pages for different lists. Whenever you send a campaign to members of a list other than 1, after sending the campaign, the subscriber page number in the database is changed to 1 (before it was 2 or 3 or whatever number).
Problem: whenever a user (of a subscriber list other than 1) wants to change his profile, he is not able to do that since his subscriber page has changed from x to 1. So now I have to alter the subscriber page in the database manually, after sending a campaign!!! That is not doable of course.
Steps To ReproduceCreate two subscriber pages, subscriber someone via subscriber page 2 and sent a test message. The subscriber page number in the database will be set to 1 after sending the message.
Additional InformationI have put this on the forum some time ago. Hope this helps.
I need to use different subscriber pages for different subjects and languages. Right now, I'm stuck only being able to send messages to members of subscriber page 1.
TagsNo tags attached.



10-05-16 12:12

manager   ~0057697

Can you link to the forum post. I seem to remember I couldn't replicate this. Will help me to refresh my memory :)


10-05-16 13:54

reporter   ~0057698

It's here:


11-05-17 20:00

manager   ~0059057

Last comment from Duncan indicates that this is a local issue.


I don't think that there is a general problem like this, because other people would report it, and also it doesn't happen for my subscribers when sending a campaign.

Looking back, the discussion about the database prefixes was inconclusive. I'm not sure that Ronald understood the need for the two prefixes to be consistent.
So far as I can see there is only one place in the phplist code where the subscriber's subscribe page is set, that is when he subscribes. So the value changing when a campaign is sent is hard to understand.
@Ronald can you give me access to your phplist and also the code on the web server and database to investigate this?