View Issue Details

IDProjectCategoryView StatusLast Update
0018102phplist applicationOtherpublic11-05-16 19:27
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Version3.2.5Fixed in Version3.2.5 
Summary0018102: A problem with the minified css file
DescriptionThere seems to be something missing in the all.min.css file. With the setting

define('USE_MINIFIED_ASSETS', true);

the home page, and all others that I tried, are not styled.

With the setting set to false then the pages are styled as expected.

In the new release
all.css 144K
all.min.css 71K

whereas in release 3.2.4
all.css 111K
all.min.css 83K

so the unminified css seems to have increased dramatically (is that deliberate?) but the minified has decreased in size.
TagsNo tags attached.

Relationships

related to 0018108 resolvedmichiel phplist version roll out and QA on 3.2.5RC1, css not working 

Activities

michiel

26-04-16 18:39

manager   ~0057673

hmm, yes. how strange.

michiel

26-04-16 19:09

manager   ~0057674


I can't find the reason for this. But also, when I delete all.min.css and rename all.css to all.min.css I get the attached page. Is there a mix going on of styles?

michiel

26-04-16 19:09

manager  

dev-css.png (53,344 bytes)
dev-css.png (53,344 bytes)

michiel

26-04-16 19:31

manager   ~0057675

On dev, the style is still fine:

http://dev.phplist.com/lists/admin/

julienl

27-04-16 12:57

reporter   ~0057677

It's OK after I've replaced the folder dressprow of the RC1 with this :

https://github.com/phpList/phplist-ui-dressprow/tree/d051c18624ad523296da77ce937e2a844300b0ec

mariez

28-04-16 02:05

developer   ~0057679

I found 3 fatal errors on all.min.css
After fix them the styles loads ok.

First Search for:
background:#eee linear-gradient(top,rgba(255,255,255,.2) 0 100%;

There is a ) missed, the right way is:
background:#eee linear-gradient(top,rgba(255,255,255,.2) 0 100%);

Second Search for:
background:#ddd linear-gradient(top,rgba(255,255,255,.3) 0 100%;

Same error, the right way is:
background:#ddd linear-gradient(top,rgba(255,255,255,.3) 0 100%);

And the third one:
background:#ccc linear-gradient(top,rgba(255,255,255,.35) 0 100%;

Same error, the right way is:
background:#ccc linear-gradient(top,rgba(255,255,255,.35) 0 100%);

mariez

28-04-16 02:08

developer   ~0057680

Anyway, styles look funny for me, with all.min, and all.css too. Menu dont have background color and other differences.

mariez

28-04-16 02:13

developer   ~0057681

MichieL: I load gray.css after all.min.css and is ok now. I think somebody missed that file on minify process.

michiel

11-05-16 19:27

manager   ~0057715

I think I fixed this, we'll see in the next release.