View Issue Details

IDProjectCategoryView StatusLast Update
0018085phplist applicationConfigurationpublic16-04-16 22:06
Reporterduncanc 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Versionnext patchFixed in Version3.2.5 
Summary0018085: Update example of using alternative phpmailer
DescriptionIn config_extended.php the example of using an alternative version of phpmailer needs updating to refer to the autoload file, instead of the phpmailer class file.

# you can specify the location of the phpMailer class here
# if not set, the version included in the distribution will be used
## eg for Debian based systems, it may be something like the example below
## when you do this, you may need to run some tests, to see if the phpMailer version
## you have works ok
#define ('PHPMAILER_PATH','/usr/share/php/libphp-phpmailer/class.phpmailer.php');


change to

# you can specify the location of the phpMailer autoload file here
# if not set, the version included in the distribution will be used
## eg for Debian based systems, it may be something like the example below
## when you do this, you may need to run some tests, to see if the phpMailer version
## you have works ok
#define ('PHPMAILER_PATH','/usr/share/php/libphp-phpmailer/PHPMailerAutoload.php');

But the phpmailer version needs to be fairly recent, since it added autoloading. I tried installing phpmailer on ubuntu and it installed an older version without autoloading.
TagsNo tags attached.

Activities

michiel

16-04-16 11:16

manager   ~0057606


maybe it should just mention both.

michiel

16-04-16 22:06

manager   ~0057607

added a mention of the autoloader