View Issue Details

IDProjectCategoryView StatusLast Update
0018072phplist applicationMessage Send Processpublic17-04-16 12:42
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Versionnext patchFixed in Version3.2.5 
Summary0018072: Progress messages not displayed when processing queue in the browser
DescriptionWhen processing the queue through the browser the progress messages are never displayed as they occur. Instead they seem to be displayed only when the process has finished and then get immediately replaced by another message.

This seems to be caused by not flushing the output buffer. See file actions/processqueue.php line 405

      print '<script type="text/javascript">
      var parentJQuery = window.parent.jQuery;
      parentJQuery("#processqueue'.$target.'").append(\'<div class="output shade'.$shadecount.'">'.$line.'</div>\');
      parentJQuery("#processqueue'.$target.'").animate({scrollTop:100000}, "slow");
      </script>';
            $shadecount = !$shadecount;
            for ($i = 0;$i < 10000; ++$i) {
                print ' ';
                if ($i % 100 == 0) {
                    print "\n";
                }
            }
        }
        flush();


After inserting ob_flush() just before flush(), the progress messages were displayed as they happened.
TagsNo tags attached.

Activities

There are no notes attached to this issue.