View Issue Details

IDProjectCategoryView StatusLast Update
0018071phpList 3 applicationAll Otherpublic04-10-16 13:13
Reportergingerling 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.2.4 
Target Versionnext minorFixed in Version 
Summary0018071: Allow specifying of prefrences page with url
DescriptionAllow something like this:

<a href=”[PREFRENCESURL]&=8””title=Your special offer preferences”</a>

to be used to send subscribers to the preference page based on subscribe page 8, regardless of what their default subscribe page is.

Full description of use being written but not yet finished.
TagsNo tags attached.

Activities

michiel

18-04-16 19:53

manager   ~0057631

Without click tracking

<a href=”[PREFERENCESURL]&=8” title=Your special offer preferences”>Special Offer</a>

works as expected.

With clicktracking enabled it doesn't, so that's where it needs to be fixed.

michiel

18-04-16 20:52

manager   ~0057632

Last edited: 18-04-16 20:57

View 3 revisions

With click tracking

 <a href=”[PREFERENCESURL]&amp ;=8” title=Your special offer preferences”>Special Offer</a>

works

michiel

18-04-16 20:58

manager   ~0057633

sorry, mantis mangles the code, but basically:

with clicktracking you need to write & amp; (without space) instead of &

gingerling

19-04-16 09:24

manager   ~0057637

I still can't get

<a href=”[PREFERENCESURL]&=8” title=Your special offer preferences”>Special Offer</a>


working with or without click tracking. From the code above I get


Special Offer=0A<=E2=80=9Dhttp://ethicalpets.hosted.phplist.com/lists/lt.ph=
p?id=3DNh8DCwNOCFNSGgQFBgA>

in the email. It's not a click-able link, guess the html isn't right. If I extract the url and move it to a browser manually I get a whitepage (see screenshot)

gingerling

19-04-16 09:24

manager  

samtuke

19-04-16 11:21

administrator   ~0057638

Last edited: 19-04-16 11:32

View 4 revisions

In the URLs above there's a missing "id" -- working URLs specifying the subscribe page template used on preferences page look like:

https://ethicalpets.hosted.phplist.com/lists/?p=preferences&uid=38f9244824d8197167732b6c3eb6c25c&id=8

In a campaign composition window (with editor GUI turned off) this looks like (linked to pastebin for 1 month as Mantis is incapable of printing code unparsed):

http://pastebin.com/pgyrzU6h

If the & character is not properly used as an HTML entity then the resulting URL will be malformed after parsing during sending. E.g. this in the campaign editor:

[PREFERENCESURL]&id=8

Will be presented in email as this malformed link, which does not properly pass the ID parameter via GET, and will result in the default preferences page being presented:

https://ethicalpets.hosted.phplist.com/lists/?p=preferences&id&uid=38f9244824d8197167732b6c3eb6c25c

Notice that the id is included as &id, not &id=8

gingerling

19-04-16 11:42

manager   ~0057639

Hi,

I have now tested this placeholder+html code

http://pastebin.com/qLZRQfqg (patebin 1 month)

with the ckeditor on and it works well, you can indeed specify the page.

any small error in the html causes big issues with the editor on though, it's all a lot easier to use with the editor off. I will mostly be using this in the footer so it's not too affected by the editor thankfully :)

Click tracking seems to work fine etc.

michiel

19-04-16 12:05

manager   ~0057641

without the editor, you need to use "& amp;" instead of "&" and it will work

gingerling

19-04-16 14:43

manager   ~0057646

yes, I think we have this working now - good stuff!

I think it always needs the amp;, it does not work at all without it - with or without the editor, but with amp it works all the time :) all good :)