phplist

NOTE:: Before reporting an issue, make sure you are running the latest version, currently 3.3.1


View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0018066phplist applicationpluginspublic31-03-16 10:3314-09-16 21:08
Reporterduncanc 
PrioritynormalSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version3.2.6 
Target Version3.2.6Fixed in Version3.2.6 
Summary0018066: Not able to install an earlier release of a plugin
DescriptionIn plugins.php there is a regex that validates the URL entered for the plugin zip file. The last part of that, to pick out the branch name, is too restrictive as it does not allow dot characters.

This is a problem if you want to install a branch that is identified by a release number, such as 1.2.3. In this case the URL of the zip file is something like https://github.com/bramley/phplist-plugin-zzzz/archive/1.2.3.zip, [^] which is rejected by the validation.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0057580)
duncanc (developer)
31-03-16 10:47

See https://github.com/phpList/phplist3/pull/53 [^]


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker