View Issue Details

IDProjectCategoryView StatusLast Update
0018031phplist applicationphpListpublic16-04-16 21:14
ReporterEhaver282 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformChrome, IEOSWindowsOS Version10
Product Version3.2.4 
Target Versionnext patchFixed in Version3.2.5 
Summary0018031: Forward Subject Incorrect
DescriptionWe are testing the message forwarding capabilities and discovered an issue. When the campaign is forwarded the subject is replaced by the data from the Meta Data Campaign Title, this information isn't suppose to show up in any outgoing email as per the info icon on the backend page. Is there a setting to use the Campaign subject instead? Or is this a bug?

Thank you,
Ernie
Steps To ReproduceCreate a Campaign.
Use Campaign Subject - Welcome to a New World!
Add content
Set Campaign Meta Data - New World Welcome Email.
Send the campaign
Click forward link
Next screen will state, at the top, Forwarding the message with subject New World Welcome EMail.

This should state Forwarding the message with subject Welcome to a New World.
TagsNo tags attached.

Activities

michiel

25-02-16 22:44

manager   ~0057534


Yes, that's most likely a bug and it needs attention. Thanks for reporting that.

michiel

01-03-16 16:32

manager   ~0057535

Hmm, strange

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/sendemaillib.php#L955

takes the same value as

https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/sendemaillib.php#L959

michiel

01-03-16 16:34

manager   ~0057536

ah, looks like it's here: https://github.com/phpList/phplist3/blob/master/public_html/lists/admin/sendemaillib.php#L1452