View Issue Details

IDProjectCategoryView StatusLast Update
0018023phpList 3 applicationAll Otherpublic01-10-18 10:38
Reportergingerling 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version3.2.4 
Target Version3.3.5Fixed in Version3.4.0 
Summary0018023: "bounces per list" file download lacks a file extension
DescriptionWhen you go to bounces per list and click a list, there is an option to download the list of mails but the file format is missing. It opens by default in plain text on my computer.
TagsNo tags attached.

Activities

michiel

18-02-16 16:08

manager   ~0057520


yes, that's how it works. What did you expect instead?

gingerling

18-02-16 16:14

manager   ~0057521

usually these files are csv, and open in calc. I get that this is one email per line with no "commas" needed to separate the value, but if it had the .csv at the end it would open in the right app by default reliably. In some situations it even opened in libreoffice writer by default (from the file manager rather than web browser for example) so I assume it might be opened in word etc. To me it seems best that data like is opened in a spreadsheet by default.

samtuke

19-09-16 09:46

administrator   ~0058263

To clarify, it seems that what Anna is describing is a missing file extension. Updated issue title to reflect this.

michiel

03-07-18 21:42

manager   ~0060835

The issue here is that the list of emails is just that: a list of emails. No additional columns that would justify a CSV extension.

There is an extension, it's just that it doesn't open in a spreadsheet.

I think this can be closed as a won't do. If we change the current behaviour that may upset people who expect to open it in a text editor (which is what it does now).

michiel

03-07-18 21:46

manager   ~0060836


Ok, spoke too soon. I just tried and indeed, it does not have an extension.

@Xheni it should be easy to add a .txt extension. I think that would be the best one to use.

xheni

10-07-18 12:06

administrator   ~0060870

Last edited: 10-07-18 12:07

View 2 revisions

@Michiel I used the csv extension because we use that one for every file : PR: https://github.com/phpList/phplist3/pull/371