View Issue Details

IDProjectCategoryView StatusLast Update
0018002phpList 3 applicationCommand Linepublic23-12-20 12:00
Reporterdennis.schnitzmeier Assigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
OSUbuntuOS Version14.04.3 LTS 
Product Version3.2.4 
Target Versionnext patch 
Summary0018002: Undefined Index when calling via Command-Line
DescriptionI got following error when I call processqueue or processbounces via command-line:

PHP Notice: Undefined index: p in /path/to/phplist/lists/admin/index.php on line 729
PHP Notice: Undefined index: c in /path/to/phplist/lists/admin/index.php on line 729

Steps To ReproduceThis are the commands used in CRON but I also get the Notice when using it in terminal:

php /path/to/phplist/lists/admin/index.php -pprocessqueue -c/path/to/phplist/lists/config/config.php

php /path/to/phplist/lists/admin/index.php -pprocessbounces -c/path/to/phplist/lists/config/config.php
Additional InformationI fixed it by changing line 729 in index.php from:

$res[$cur] .= $clinearg;

to:

if(isset($res[$cur])){
  $res[$cur] .= $clinearg;
} else {
  $res[$cur] = $clinearg;
}
TagsNo tags attached.

Activities

jachhunter777

11-12-20 08:10

reporter   ~0063630

Last edited: 11-12-20 12:43

View 2 revisions

php /path/to/phplist/lists/admin/index.php -pprocessbounces -c/path/to/phplist/lists/config/config.php
I fixed it by changing line 729 in index.php from:

$res[$cur] .= $clinearg;

to:

if(isset($res[$cur])){
  $res[$cur] .= $clinearg;
} else {
  $res[$cur] = $clinearg;
}

michiel

11-12-20 11:55

administrator   ~0063632

Feel free to open a PR on Github to get that fixed.

duncanc

11-12-20 12:28

updater   ~0063633

@michiel that user jachhunter777 seems to be spamming, see the goo.gl URL. Can you ban them?

michiel

11-12-20 12:43

administrator   ~0063634

ok, done

duncanc

12-12-20 11:42

updater   ~0063638

See https://github.com/phpList/phplist3/pull/722

mariana

14-12-20 12:23

administrator   ~0063655

This was resolved with https://github.com/phpList/phplist3/pull/722